Using the Batch Wizard (tick_24Pro, cross_24Std)

These general steps will help you get started using the Batch Wizard.

Using the Batch Wizard

1.Open the Batch Wizard. Run CSS HTML Validator Pro or Enterprise and then go to Tools->Batch Wizard or press F2. Note that the Batch Wizard is not available in the standard edition.

2.Create a new target list or load a saved list. Choose File->New List or press Ctrl+N to create a new target list, or you can load an previously saved target list with File->Open List.

3.Add targets to the list. For new Batch Wizard jobs, create a list of targets that you want to process (i.e. validate). This is called a target list. Targets can be files, URLs, or folders. To add targets, use the Target menu, toolbar, or the context/pop-up menu for the Target List tab. You can also drag and drop files and folders onto the target list to add them. Duplicate targets that are already in the target list cannot and will not be added again.

4.For website validation, add the website's root URL or file. Add a target that specifies the root page of your website. This can be a URL or a local file. To add a local file target, press Ctrl+F. To add a URL, press Ctrl+U. For example, if your site is at "https://www.mydomain.com/mysite/" then press Ctrl+U to add the URL "https://www.mydomain.com/mysite/" to the target list. You can also specify a folder where your website files are located by adding a folder target (Ctrl+D).

5.View and edit each target's properties (if needed). If you want to change any target options (like the Follow links option that specifies whether you want to follow a target's links or not), then select the target and press F5 to view and edit the target's properties and to make the desired changes in the Target Properties dialog. If you want to validate a website and crawl (follow) the links then select the target, press F5, select the Follow Links tab (if not already selected) and enable the Follow links option. Click OK when you are finished viewing and editing a target's properties.

6.Setup the target list options (optional). Select the Target List Options tab and set the options specific to the current target list. These options allow finer control over which targets to include and exclude, which links to check, and more.

7.Save the target list. After you've added all the targets to the target list (or made changes to an existing list), we recommend that you save the target list (though this is not required). You can do this by choosing File->Save List. Choose a suitable filename and folder to save the target list to.

8.Setup the job options. Go to Options->Batch Wizard Options, press F4, or use the button on the toolbar, then make the desired changes (if any). For example, if you're validating a website then go to the Tool to Use page and select the Validator tool as the tool to use. You can also optionally select a validation mode, like 'Full', 'Errors only' or 'Errors and warnings only'. Select OK when done

9.Start the job. Select File->Start Processing, press the Start button on the toolbar, or press F6 to start processing the target list. The progress will be displayed in the Batch Progress tab. If you want to abort the processing, then you can press the Stop button on the toolbar (or press F7). Depending on where the Batch Wizard is in the processing cycle will determine how long it is until the processing is actually aborted so you may have to wait a few seconds for the processing to stop after you hit the Stop button.

10.View the report. If you've used the validator, spell check, or link check tool that generates a report then you can view the report when the processing is completed. When completed, the report will open automatically (unless you've set the option to not automatically open the report). Reports are typically in HTML format and are opened in your default web browser. Note that some tools, such as the template tool, do not generate reports and so there is no report to view.

11.Repeat when desired. To process the list again press the Start button (or press F6) again. To make sure that all targets are processed again, you may first want to choose Target->All Targets->Set Process to Yes.

NOTE: The trial version may be limited to checking a small number of documents so that the limited number of trial validations are not quickly used up. To fully use the Batch Wizard, a licensed version is required. Also note that large websites may require the enterprise edition's capability to handle larger jobs (the enterprise edition also includes additional Batch Wizard features).

Using the Batch Wizard Directly from the Editor

You can use the Batch Wizard to quickly generate an HTML validation report for the web document that you are editing in HTML Validator's integrated editor by selecting Validate->Validate with Batch Wizard or by pressing Shift+F2 in the integrated editor.

To validate all the non-empty documents that are open in the editor and that are recognized (by file extension) as checkable documents, select Validate->Validate All with Batch Wizard or press Alt+F2.

More Information

See the Batch Wizard topic for more information about the Batch Wizard.

See the Batch Wizard Tips topic for some tips.

See the Batch Wizard Troubleshooting topic if you encounter problems.

Batch Wizard jobs can be run from the command line.