Search found 3464 matches

by Albert Wiersch
Mon Dec 02, 2019 10:19 am
Forum: Accessibility
Topic: Solution for warning 'No "skip to" link detected' for accessibility
Replies: 6
Views: 366

Re: Solution for warning 'No "skip to" link detected' for accessibility

Hello, On the page you linked to, there are links to more information like this page: https://www.w3.org/TR/2016/NOTE-WCAG20-TECHS-20161007/G1 There are also some examples here (although the last update was in 2009): https://www.jimthatcher.com/skipnav.htm Basically the validator is looking for "a" ...
by Albert Wiersch
Mon Dec 02, 2019 9:45 am
Forum: Accessibility
Topic: Enhancement suggestion: Color Calculator
Replies: 3
Views: 181

Re: Enhancement suggestion: Color Calculator

Hello, Thank you for the suggestion. The thought of adding something like this has occurred to me before. I think it would be best if I could just "integrate" with one of the online contrast checkers that already exists. Perhaps I could add a link to the validator contrast message to the online cont...
by Albert Wiersch
Tue Nov 26, 2019 9:30 am
Forum: Technical Support
Topic: Figure/figcaption: strange message
Replies: 1
Views: 256

Re: Figure/figcaption: strange message

Hello, The complete message is: The "figure" element does not contain an optional "figcaption" element. The "figcaption" element can be used as the first or last child of a "figure" element to provide a caption or legend. This message is displayed up to 3 times. Please move the "figcaption" element ...
by Albert Wiersch
Mon Nov 18, 2019 8:45 am
Forum: Scripting Languages
Topic: JavaScript "localStorage"
Replies: 5
Views: 315

Re: JavaScript "localStorage"

Thank you Lou. I took a look. I think the problem is that localStorage and sessionStorage only store string values. When you try to save an object to it (like with sessionStorage.setItem("savedWindow", displayWindow) ), the literal string "[object Window]" is saved and not the object that you need. ...
by Albert Wiersch
Sat Nov 16, 2019 5:53 pm
Forum: Scripting Languages
Topic: JavaScript "localStorage"
Replies: 5
Views: 315

Re: JavaScript "localStorage"

Hi Lou,

Well this isn't my area of "expertise" but I may be able to "play" with it a little and see if I can figure anything out. :D

Can you create a small ZIP file of all the files needed (PHP, HTML, CSS, JS, etc) to reproduce/simulate the problem and attach the ZIP file to a forum reply?
by Albert Wiersch
Sat Nov 16, 2019 9:11 am
Forum: Technical Support
Topic: Amp error
Replies: 6
Views: 652

Re: Amp error

UPDATE: We've significantly improved AMP HTML checking for the upcoming major release (2020/v20). If you'd like to test an early BETA of it and provide feedback then please send me a private message.
by Albert Wiersch
Thu Nov 14, 2019 6:53 pm
Forum: HTML and XHTML
Topic: HTML Code Not Working When Ebbeded
Replies: 4
Views: 314

Re: HTML Code Not Working When Ebbeded

Hello Albert. Just found this out. We're using Google Sites and they do not allow popup windows! So, a print button will never work. Thanks for your help and I really appreciate your time and efforts. Regards, Michael You're welcome! I had also thought that something might be blocking it. Thank you...
by Albert Wiersch
Thu Nov 14, 2019 12:37 pm
Forum: HTML and XHTML
Topic: HTML Code Not Working When Ebbeded
Replies: 4
Views: 314

Re: HTML Code Not Working When Ebbeded

Maybe a conflict with the function name printpage and another function or variable?

Does this work?

Code: Select all

<button onclick="window.print()">PRINT</button>
by Albert Wiersch
Wed Nov 13, 2019 10:20 pm
Forum: Scripting Languages
Topic: only image icon shows up
Replies: 5
Views: 359

Re: only image icon shows up

Then $staff_pic_file must be a bad/invalid URL. What does $staff_pic_file equal when it doesn't work? And when it works?

Going to need a lot more information to debug. Without more detail, it will be very difficult to debug.
by Albert Wiersch
Wed Nov 13, 2019 10:32 am
Forum: Scripting Languages
Topic: only image icon shows up
Replies: 5
Views: 359

Re: only image icon shows up

Hello,

Have you checked the server/PHP logs for messages that might be helpful?

What is the HTML source code that is being generated by the PHP that is showing the image icon?
by Albert Wiersch
Tue Nov 12, 2019 4:52 pm
Forum: Site Promotion & SEO (Search Engine Optimization)
Topic: Old SEO is finally dead
Replies: 10
Views: 6508

Re: Old SEO is finally dead

Thank you Mike. I just got around to reading the searchengineland link. Very interesting and also worrisome that Google has so much power and is putting so many ads on their search results pages now that organic results don't even show on some mobile searches unless one scrolls down. When I do a sea...
by Albert Wiersch
Tue Nov 12, 2019 10:51 am
Forum: General Web Development
Topic: Calls on first install of a browser
Replies: 1
Views: 470

Re: Calls on first install of a browser

A little late to reply but I did look at this when you posted it. Very interesting.... a little surprising that there are so many calls but at the same time it's not that surprising.
by Albert Wiersch
Mon Nov 11, 2019 9:26 am
Forum: Technical Support
Topic: SDK for HTML validator / custom menu icons
Replies: 3
Views: 208

Re: SDK for HTML validator / custom menu icons

Hello, Yes! That is correct. I'm glad you were able to figure it out. If there is something in the documentation that would have helped you figure it out faster then please let me know. I'm always looking to improve the documentation as well. And don't forget you can press F4 to repeat the last Text...
by Albert Wiersch
Thu Nov 07, 2019 9:30 pm
Forum: Technical Support
Topic: overflow-y AMP HTML error
Replies: 3
Views: 302

Re: overflow-y AMP HTML error

Hi Adrian, Is the CSS with "overflow-y: auto" user defined CSS (thus not part of an AMP HTML component)? Or is it part of an AMP HTML component? If it's user defined (it looks like it is user defined to me but I am not certain) then I believe the validator message is correct per the link I posted in...
by Albert Wiersch
Mon Nov 04, 2019 11:47 am
Forum: Technical Support
Topic: overflow-y AMP HTML error
Replies: 3
Views: 302

Re: overflow-y AMP HTML error

I found a new error, that in amp developer site is not reported, but it's used: The "overflow-y" CSS property may not be styled as "auto" or "scroll". User defined elements in AMP documents may not have a scrollbar. Hello, Please see: https://amp.dev/documentation/guides-and-tutorials/learn/spec/am...