Search found 45 matches

by TomHTML
Tue Mar 26, 2019 11:20 am
Forum: HTML and XHTML
Topic: content attribute with URLs in meta tags
Replies: 3
Views: 3100

Re: content attribute with URLs in meta tags

It's happy with <meta itemprop=image content="images/acme-logo.jpg"> though. That's what puzzles me.
by TomHTML
Mon Mar 25, 2019 4:31 pm
Forum: HTML and XHTML
Topic: content attribute with URLs in meta tags
Replies: 3
Views: 3100

content attribute with URLs in meta tags

The Yandex structured data checker ( https://webmaster.yandex.com/tools/microtest/ ) reported a surprising error to me: ERROR: The 'content' property of a meta tag can't contain a URL It was in reference to this block: <!DOCTYPE html> <html lang=en-us prefix="og: http://ogp.me/ns#" itemscope itemtyp...
by TomHTML
Sun Nov 11, 2018 6:39 pm
Forum: Technical Support
Topic: XML namespace error message
Replies: 1
Views: 2185

XML namespace error message

The Validator indicates xmlns:svgjs="http://svgjs.com/svgjs" in the HTML below is an error, explaining: Attributes of the form xmlns:prefix (like this "xmlns:svgjs" attribute) must not be used in HTML (but can be used in XHTML) <svg id="SvgjsSvg1006" width="300" height="300" xmlns="http://www.w3.org...
by TomHTML
Thu Oct 11, 2018 12:01 pm
Forum: Technical Support
Topic: 'background-clip' problem
Replies: 1
Views: 3672

'background-clip' problem

There's double jeopardy on 'background-clip' when the value is 'text' within the Validator. If I use "-webkit-background-clip: text;" in my CSS, the validator reports: The "-webkit-background-clip" vendor prefixed property is now considered obsolete and/or useless. Today, it is recommended that only...
by TomHTML
Thu Oct 11, 2018 9:44 am
Forum: Technical Support
Topic: Possible bug on complex CSS selector?
Replies: 3
Views: 2625

Re: Possible bug on complex CSS selector?

Thanks! I've installed and run it, and the bug seems to be patched! Many thanks!
by TomHTML
Thu Oct 11, 2018 12:30 am
Forum: Technical Support
Topic: Possible bug on complex CSS selector?
Replies: 3
Views: 2625

Possible bug on complex CSS selector?

The validator complains that this CSS selector is invalid, yet the W3 HTML and CSS checkers approve it (and it works for styling my elements): .block .block-content a[href*="//"][target*="_blank"]:not(.image-overlay):not([href*="example.com"])::after It complains about *="example.com", stating: Ther...
by TomHTML
Fri Apr 20, 2018 1:12 pm
Forum: Technical Support
Topic: Custom element support?
Replies: 5
Views: 3975

Re: Custom element support?

Great to hear. Also, you might look at the spec for Polymer, which is used for Material Icons design. It also uses custom tags that simply employ a hyphen in the element name, but there's no consistent prefix like "amp"; they simply follow the HTML spec for allowing custom tags so long as a hyphen i...
by TomHTML
Wed Apr 18, 2018 7:21 pm
Forum: Technical Support
Topic: Custom element support?
Replies: 5
Views: 3975

Re: Custom element support?

I recently began studying AMP coding, and it turns out to make use of custom elements extensively. Apparently, all AMP custom elements begin with the prefix "amp-", e.g.: <amp-img src="welcome.jpg" alt="Welcome" height="400" width="800"></amp-img> An example AMP page that makes extensive use of them...
by TomHTML
Fri Apr 06, 2018 12:52 am
Forum: Technical Support
Topic: How to validate the resulting HTML of an SPA?
Replies: 5
Views: 3475

Re: How to validate the resulting HTML of an SPA?

Excellent! I followed your instructions, and I can copy the outer html of the main HTML element in the Chrome and Firefox developer's tools, and the Validator brings it in and validates it. Previously, I had been copying and pasting the code from the developer's tools; this eliminates the pasting & ...
by TomHTML
Thu Apr 05, 2018 1:19 am
Forum: Technical Support
Topic: How to validate the resulting HTML of an SPA?
Replies: 5
Views: 3475

How to validate the resulting HTML of an SPA?

I have an SPA site whose JavaScript edits the HTML after it has been loaded into the browser. The browser display in the validator is accurate: it renders the page exactly as it would appear in Chrome, Firefox, etc. But the validator returns a report on the HTML as it would initially be received by ...
by TomHTML
Fri Mar 23, 2018 9:02 pm
Forum: Technical Support
Topic: application/ld+json script in head element
Replies: 1
Views: 2509

application/ld+json script in head element

I'm employing an application/ld+json script with schema information, including a bread crumb list, etc., in the head element. The validator responds to it this way: When designing web pages, consider that scripts and programmatic objects pose potential accessibility problems for users: 1) some user ...
by TomHTML
Thu Mar 22, 2018 11:48 am
Forum: Technical Support
Topic: Custom element support?
Replies: 5
Views: 3975

Custom element support?

Is there a reason why the validator does not recognize custom elements that conform to this spec? https://developer.mozilla.org/en-US/docs/Web/Web_Components/Using_custom_elements I tried using <x-nav> as an element, and the validator complained, "The "x-nav" element is not valid. Is it misspelled?"...
by TomHTML
Sun Mar 18, 2018 10:42 am
Forum: Technical Support
Topic: Validator is misidentifying some images as identical
Replies: 2
Views: 2533

Validator is misidentifying some images as identical

Different base64 encoded images are being misidentified as being the same image by the validator, and it is issuing the following warning: This image has alt text that does not match the previously used alt text for this same image. What I believe is happening is that the validator is only reading a...