Search found 45 matches

by TomHTML
Wed Mar 07, 2018 9:23 am
Forum: HTML and XHTML
Topic: Location of charset meta tag (and other head elements)
Replies: 2
Views: 2684

Location of charset meta tag (and other head elements)

First, let me praise your work on this program. It's really quite remarkable, and seems to be a true labor of love. Tools that provide such comprehensive information are rare, and this is one of them. I've barely skimmed the surface of everything that can be done with it, and it's already proving he...
by TomHTML
Mon Mar 05, 2018 3:55 pm
Forum: Technical Support
Topic: Correct MIME types for webfonts?
Replies: 2
Views: 12463

Re: Correct MIME types for webfonts?

Thank you! That is very helpful!
by TomHTML
Sat Mar 03, 2018 7:12 pm
Forum: Technical Support
Topic: Correct MIME types for webfonts?
Replies: 2
Views: 12463

Correct MIME types for webfonts?

I had been receiving an error from the validator on the correct mime type to receive for WOFF2 fonts. My server was sending out mime types following this prescription in my .htaccess file: AddType application/x-font-ttf ttc ttf AddType application/x-font-otf otf AddType application/font-woff woff Ad...
by TomHTML
Fri Mar 02, 2018 9:42 pm
Forum: Technical Support
Topic: Message Window text doesn't clear out in browser mode
Replies: 1
Views: 2027

Message Window text doesn't clear out in browser mode

The newest version is great! I have found one little problem, though: when using the "browser" tab to feed in URLs, one of my pages had some links with 301 redirects. I found the current URLs of those redirects and revised my code, and the Validator did not raise an error. However, the previous erro...
by TomHTML
Fri Mar 02, 2018 9:38 pm
Forum: Technical Support
Topic: Incorrect media type reported for self-hosted CSS, ICO, and XML
Replies: 10
Views: 4467

Re: Incorrect media type reported for self-hosted CSS, ICO, and XML

I've just put the new version through some paces, and it seems to work beautifully! Many thanks!
by TomHTML
Wed Feb 21, 2018 12:30 am
Forum: Technical Support
Topic: Incorrect media type reported for self-hosted CSS, ICO, and XML
Replies: 10
Views: 4467

Re: Incorrect media type reported for self-hosted CSS, ICO, and XML

Great news! I'll look forward to the update. As for the second method you asked about (File->Open From Web), when I do that, it loads the HTML into the editor (a dialogue window appears first, showing connection info). When I then click on 'Validate', it shows errors in red, even though the ABS path...
by TomHTML
Tue Feb 20, 2018 9:37 am
Forum: Technical Support
Topic: Incorrect media type reported for self-hosted CSS, ICO, and XML
Replies: 10
Views: 4467

Re: Incorrect media type reported for self-hosted CSS, ICO, and XML

Hi Albert, The URL you supplied doesn't validate, with the same problem I encountered. See the attached screen shot. At the bottom of the screen, the link is css/my-styles.css The ABS is https://www.htmlvalidator.com/test/20180220/css/mystyles.css The editor shows the base tag as <base href=https://...
by TomHTML
Tue Feb 20, 2018 12:01 am
Forum: Technical Support
Topic: Incorrect media type reported for self-hosted CSS, ICO, and XML
Replies: 10
Views: 4467

Re: Incorrect media type reported for self-hosted CSS, ICO, and XML

I've discovered the problem: the validator is relying on the URL for resolving relative paths, even when there is a <base> element with an href indicating where the relative paths are actually to be resolved. In my case, I have an SPA site where the URL might be: https://mysite.com/home/blog-post-1 ...
by TomHTML
Sun Feb 18, 2018 9:52 pm
Forum: Technical Support
Topic: Incorrect media type reported for self-hosted CSS, ICO, and XML
Replies: 10
Views: 4467

Incorrect media type reported for self-hosted CSS, ICO, and XML

The validator is issuing similar complaints about CSS, ICO, and XML files on my own site as it did for the fonts hosted by Google. I've tried to ensure that the right type is being issued via .htaccess directives, but it's to no avail. Here's what's relevant in my .htaccess file: <IfModule mod_mime....
by TomHTML
Wed Feb 07, 2018 7:32 pm
Forum: Technical Support
Topic: How to resolve font-face issues?
Replies: 8
Views: 5013

Re: How to resolve font-face issues?

Just installed and checked it, and yes, it works! They're all commented in green at the bottom of the links list. I like the new message as well. Many thanks!
by TomHTML
Mon Feb 05, 2018 11:29 pm
Forum: Technical Support
Topic: How to resolve font-face issues?
Replies: 8
Views: 5013

Re: How to resolve font-face issues?

Hmm, when I therefore edit the first link--which was indicated with a red square in the validator listing, suggesting the severity of the issue--this way: <link rel="preload" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/fonts/fontawesome-webfont.woff2" as="font" type="application/...
by TomHTML
Mon Feb 05, 2018 8:33 pm
Forum: Technical Support
Topic: How to resolve font-face issues?
Replies: 8
Views: 5013

Re: How to resolve font-face issues?

For all but the 'ttf' font types I listed are now recognized by the validator without raising any issues; the 'ttf' issue remains, and 'woff2' now seems problematic. For: <link rel=preload href=https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/fonts/fontawesome-webfont.woff2 as=font type=fon...
by TomHTML
Mon Feb 05, 2018 8:23 pm
Forum: Technical Support
Topic: og:image:secure_url error message in error itself?
Replies: 3
Views: 2164

Re: og:image:secure_url error message in error itself?

Thanks! That solved the secure_url problem.
by TomHTML
Sun Feb 04, 2018 11:19 am
Forum: Technical Support
Topic: How to resolve font-face issues?
Replies: 8
Views: 5013

How to resolve font-face issues?

Provided this font-face definition: @font-face { font-family: 'Noto Sans'; font-weight: 400; font-style: normal; src: url(https://fonts.gstatic.com/s/notosans/v6/LeFlHvsZjXu2c3ZRgBq9nPY6323mHUZFJMgTvxaG2iE.eot); src: url(https://fonts.gstatic.com/s/notosans/v6/LeFlHvsZjXu2c3ZRgBq9nPY6323mHUZFJMgTvxa...
by TomHTML
Sun Feb 04, 2018 10:28 am
Forum: Technical Support
Topic: og:image:secure_url error message in error itself?
Replies: 3
Views: 2164

og:image:secure_url error message in error itself?

For this element: <meta property=og:image:secure_url content=https://my-url.com/OG-MINE.jpg> or even expressed this way: <meta property=og:image:secure_url content="https://my-url.com/OG-MINE.jpg"> ...I receive this error message: When property="og:image:secure_url", the "content" value should be an...