mailto generating BAD - DNS A HREF errors

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
kennedyrt
Rank II - Novice
Rank II - Novice
Posts: 20
Joined: Fri Nov 09, 2007 9:57 pm
Location: Kent, Washington

mailto generating BAD - DNS A HREF errors

Post by kennedyrt » Thu Aug 18, 2011 12:05 pm

When checking the entire website http://www.dmhs.org/, all <a> tags that contain a "mailto:" address are generating the following error:

Example: mailto:info@dmhs.org BAD - DNS A HREF - DNS problem with "dmhs.org" (9003: DNS name does not exist)

The domains do exist and are functioning properly.

I am using CSE HTML Validator Professional v10.02 - 32 bit Editor v10.0211 (pro); Engine DLL v10.0211 (Pro) under Windows 7 Enterprise.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3453
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: mailto generating BAD - DNS A HREF errors

Post by Albert Wiersch » Thu Aug 18, 2011 4:21 pm

Hello,

I cannot reproduce this as it comes up OK for me. It could be a temporary DNS issue or some kind of "fluke". You might want to clear your link cache and try re-checking or just exit and reload CSE HTML Validator.

If this doesn't help, then please let me know. You may want to try other email addresses, like our support email address - support at htmlvalidator dot com. I wonder if it could also be do to specific settings on your machine? Like a custom "hosts" file?
Image
Albert Wiersch

Daniel Lacroix
Rank III - Intermediate
Rank III - Intermediate
Posts: 92
Joined: Sat Dec 11, 2004 2:38 pm
Contact:

Re: mailto generating BAD - DNS A HREF errors

Post by Daniel Lacroix » Fri Feb 03, 2012 10:51 am

Hi Albert,

We have moved to a new network infrastructure and I have less permissions ... browsing web sites is limited.

I am still able to check the internal and external links correctly but not the mailto's.

Here is the error I am now getting:
DNS problem with "tbs-sct.gc.ca" (9501: No records found for given DNS query)

This is our own DNS!

Would you be able to describe how the mailto's are checked so that I could ask for more privileges.
Do I need a specific port open?, etc.

Thanks.

Daniel.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3453
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: mailto generating BAD - DNS A HREF errors

Post by Albert Wiersch » Sat Feb 04, 2012 8:30 am

Hi Daniel,

For mailto's, CSE HTML Validator uses DnsQuery():
http://msdn.microsoft.com/en-us/library ... 85%29.aspx

Something like this:
DnsQuery_W(domainname,DNS_TYPE_MX,DNS_QUERY_STANDARD,NULL,&dnsrecord,NULL);

If you can't get it to work, then you can try disabling DNS record checking in the Link Checking options of the Validator Engine Options.

I hope this helps.
Image
Albert Wiersch

Daniel Lacroix
Rank III - Intermediate
Rank III - Intermediate
Posts: 92
Joined: Sat Dec 11, 2004 2:38 pm
Contact:

Re: mailto generating BAD - DNS A HREF errors

Post by Daniel Lacroix » Thu Feb 09, 2012 12:15 pm

Thanks Albert.

Daniel.

Post Reply