Ignoring spelling in html comments

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Ignoring spelling in html comments

Post by RSteinwand » Tue Sep 10, 2013 2:04 pm

Hi Albert,

I'm noticing complaints about spelling errors in my Dreamweaver template comments. I suspect this behavior has been there since I first started using CSE. :D

Code: Select all

<!DOCTYPE html>
<html lang="en-US"><!-- InstanceBegin template="/Templates/public_template.dwt" codeOutsideHTMLIsLocked="false" -->
<head>
	<meta charset="utf-8" />
	<meta name="viewport" content="width=device-width" />
	<!-- InstanceBeginEditable name="title" -->
	<title>Page Not Found</title>
	<!-- InstanceEndEditable -->
	<link href="/css/default2013.css" rel="stylesheet" type="text/css" />
	<!-- InstanceBeginEditable name="style" -->
	<style type="text/css">
		#main{margin-right:0}
	</style>
	<!-- InstanceEndEditable -->
	<!--[if lte IE 7]>
	<style type="text/css">#container{width:800px}#mainContent{margin-right:-1px}</style>
	<![endif]-->
	<style type="text/css" media="print">
		.no-print{display:none}.pagebreak{page-break-after:always}body{background:#fff}#nav{display:none}#sidebar{border-top:1px solid #FC0;border-radius:10px 0 0 10px;background-clip:padding-box}
		#container{width:100%;border-radius:0;background-clip:padding-box;box-shadow:0 0 0 #000;background:#fff;margin:0 auto;border:0}
	</style>
	<!-- InstanceBeginEditable name="head" -->
	<!-- InstanceEndEditable -->
</head>
<body>
<div id="container">
	<div id="contentbg">
		<div id="header">&nbsp;</div>
		<!-- InstanceBeginEditable name="NavLocation" -->
		<div id="nav">
			<!-- InstanceEndEditable -->
			<ul class="primary"><li id="navhome"><a href="/" title="Home page">SFF Home</a></li><li id="navabout"><a href="/about.html" title="About us">About Us</a></li><li id="navapp"><a href="/appform.html" title="Application Form">Applications</a></li><li id="navwinners"><a href="/winners.html" title="Past Winners">Past Winners</a></li><li id="navprivacy"><a href="/privacy.html" title="Privacy Policy">Privacy Policy</a></li></ul>
		</div>
		<div id="content">
			<div class="iPad">
				<!-- InstanceBeginEditable name="Body" -->
				<div id="main">
					<div style="width:195px;margin-top:5px" class="float-left"><img src="http://images.godaddy.com/hosting/hdr_sorry_small.gif" width="195" height="65" class="float-left" alt="" /></div>
					<h1>We're sorry</h1>
					<p>The page you tried to access does not exist on this server.</p>
					<p>The URL that you have entered in your browser is incorrect. Please re-enter the URL and try again or click <a href="/">here</a> to go to our home page.</p>
				</div>
				<!-- InstanceEndEditable -->
			</div>
		</div>
		<!-- InstanceBeginEditable name="sidebar" -->
		<!-- InstanceEndEditable -->
		<br class="fbotspacer" />
	</div>
	<div id="footer">
		<p id="copyright"></p>
	</div>
</div>
<script src="/scripts/allscripts_pub.js" type="text/javascript"></script>
<!-- InstanceBeginEditable name="PostScript" -->
<script type="text/javascript">
	function SavePrefs(){}
	function LoadPrefs(){}
</script>
<!-- InstanceEndEditable -->
<script type="text/javascript">if(window.addEventListener){window.addEventListener("load",LoadPrefs,false);window.addEventListener("unload",SavePrefs,false);}else if(window.attachEvent){window.attachEvent("onload",LoadPrefs);window.attachEvent("onunload",SavePrefs);}else{window.onload=LoadPrefs;window.onunload=SavePrefs;}Copyright();</script>
</body>
<!-- InstanceEnd --></html>
Possibly misspelled words (4, 4 unique): NavLocation (1x), PostScript (1x), SFF (1x), template.dwt (1x). Complete list. 100 total words checked (36 in comments).
I didn't see a way to disable this in the spelling options (and it's a very low priority for me).

Thanks.
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Ignoring spelling in html comments

Post by Albert Wiersch » Tue Sep 10, 2013 2:14 pm

Hi Rick,

There should be an option to do this in the 'Spell Checking' page of the Validator Engine Options (not the Editor Options).

You can uncheck the 'Check spelling in HTML comments' option. I think that will do what you want.
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Ignoring spelling in html comments

Post by RSteinwand » Tue Sep 10, 2013 2:18 pm

You have spelling options in more places than I knew you had places... :D

I assumed Editor... spelling options, since there were so many options there, it had to be all of them.

Yup, found it and it only finds one now.

Thanks.
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Ignoring spelling in html comments

Post by Albert Wiersch » Tue Sep 10, 2013 4:39 pm

Great.

I should add another button in the 'Spell Checking' page of the Editor Options to open the Validator Engine Options 'Spell Checking' page. Both pages are related, but different. :D
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Ignoring spelling in html comments

Post by RSteinwand » Tue Sep 10, 2013 6:26 pm

Great idea!
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Ignoring spelling in html comments

Post by Albert Wiersch » Thu Sep 19, 2013 4:38 pm

Done!

Image
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Ignoring spelling in html comments

Post by RSteinwand » Thu Sep 19, 2013 4:48 pm

Nice!
Rick

Post Reply