Page 1 of 1

excluding directories

Posted: Thu Apr 03, 2014 8:12 pm
by roedygr
I have a large directory tree to validate. Each directory has a /foot directory
Is there a way to tersely avoid all the /foot directories, like you can in SVN?

Re: excluding directories

Posted: Thu Apr 03, 2014 10:31 pm
by Albert Wiersch
Hello,

You can load the target list and then go to the 'Target List Options' tab and use this in the 'Don't process these targets' option: */foot/*

Or you may have to use (with backslash instead of forward slash): *\foot\*

Re: excluding directories

Posted: Fri Apr 11, 2014 2:03 pm
by roedygr
Albert Wiersch wrote:Hello,
Or you may have to use (with backslash instead of forward slash): *\foot\*
I tried both with \ and /. It is ignored.
See attached screenshot

Re: excluding directories

Posted: Fri Apr 11, 2014 2:04 pm
by roedygr
I foot etc are names of directories. Should I be using file names?

Re: excluding directories

Posted: Fri Apr 11, 2014 2:18 pm
by Albert Wiersch
Hello,

It looks like you're putting it in the wrong place. Please try moving it to 'Don't process these targets' instead of 'Don't check these links'.

Re: excluding directories

Posted: Fri Apr 11, 2014 5:04 pm
by roedygr
Great! it is working now. Your help says:

Strings separated by semicolons; targets that match are NOT processed.

I suggest this:

Strings separated by semicolons; targets that match are NOT processed. e.g. */include/* to avoid processing all directories named include.

similarly for the link exclude. I doubt anyone ever uses this feature simply for lack of an example. There are so many wildcard schemes out there.

Re: excluding directories

Posted: Fri Apr 11, 2014 5:30 pm
by Albert Wiersch
Great! I'm glad it's working. :D

Rather than try to squeeze too much information in the help hint, I just added "Press F1 for more information.". If you press F1, then it should take you to a help page with detailed information (and some examples) on the options.

Re: excluding directories

Posted: Fri Apr 11, 2014 7:17 pm
by roedygr
roedygr wrote:Great! it is working now..
oops I spoke too soon

*\foot\*;*\include\*;*\snippet\*;*\embellishment\*

is letting through files of the form the E:\mindprod\book\foot\9781449311520.html
I think it looked like it was working because the cache mechanism was filtering out the foot files.

My script looks like this:
<?xml version="1.0"?>
<csebatchwizardtargetlist version="8">
<options htmlreportfilename="C:\temp\batchreport.html" functionsfilename="E:\env\htmlval\cache.script" excludestrings="*\foot\*;*\include\*;*\snippet\*;*\embellishment\*" />
<target flags="1069547546" target="E:\mindprod" />
</csebatchwizardtargetlist>

Re: excluding directories

Posted: Fri Apr 11, 2014 7:33 pm
by Albert Wiersch
I see the problem. The cache code was overriding those exclusions.

I've updated the "caching code" here:
http://www.htmlvalidator.com/CSEForum/v ... 9021#p9021

Please update to that. I added this line:

Code: Select all

 if !$otca_add return;
So if the target's default is to not process the target because you have excluded it, then the cache code will not override it.

Re: excluding directories

Posted: Fri Apr 11, 2014 9:12 pm
by roedygr
S U C C E S S

both the problem with the missing "luke" cache files is fixed, and so is *\foot\*.

Thank you. It is so fast! I afford to validate everything much more frequently.

Re: excluding directories

Posted: Fri Apr 11, 2014 10:00 pm
by Albert Wiersch
roedygr wrote:Thank you. It is so fast! I afford to validate everything much more frequently.
You're very welcome!

I knew we'd get everything ironed out sooner or later. :mrgreen: