Help-System Online/Offline out of sync

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
ReneK
Rank II - Novice
Rank II - Novice
Posts: 31
Joined: Sun Jun 16, 2013 10:27 am

Help-System Online/Offline out of sync

Post by ReneK » Thu May 29, 2014 12:53 pm

Hi,

the Online/Offline Help-Systems seem to be out of sync. In the online-help, for example, you find "checkString/Ex" under "Tag Name Programming Language" -> "Function Reference" -> "Integer", whereas the same description is located in the chm under "Tag Name Programming Language" -> "Function Reference" -> "String", which is kind of confusing. Other functions aren't documented offline at all. I looked for "getStringStartIndex" (wasn't clear if it is case sensitive or not), but I could not find it in the chm. On the other hand, it is described very well on the website.

It would be great if you had some time left to get both help-systems more in sync.

Rene

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3453
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Help-System Online/Offline out of sync

Post by Albert Wiersch » Thu May 29, 2014 1:42 pm

Hi Rene,

The documentation should be in sync if you are looking at the documentation for the same major version.

For example, for v14 use this for the online documentation:
http://www.htmlvalidator.com/v140/docs/index.html

It should match with the documentation for the CHM that comes with v14. There may be some minor differences depending on what minor update you have (14.01 vs. 14.02 vs 14.00, etc) but the differences should only be minor (with possibly a few exceptions).

getStringStartIndex() has been renamed to stripos() in v14 (but getStringStartIndex() still works).

If you have any more questions or comments on the documentation, then please let me know.
Image
Albert Wiersch

ReneK
Rank II - Novice
Rank II - Novice
Posts: 31
Joined: Sun Jun 16, 2013 10:27 am

Re: Help-System Online/Offline out of sync

Post by ReneK » Thu May 29, 2014 2:12 pm

Hi Albert,

I checked my online-help reference and yes, you're absolutely right, I was on v9 and not on v14. And now that we are talking about it, I can see that you replaced getStringStartIndex by stripos (which makes it absolutely clear that it works not case sensitive). Thanks for clarification.

But please consider replacing getStringStartIndex by stripos within your samples as well.

Rene

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3453
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Help-System Online/Offline out of sync

Post by Albert Wiersch » Thu May 29, 2014 3:28 pm

ReneK wrote:But please consider replacing getStringStartIndex by stripos within your samples as well.
Done! It will be in the next update. Thank you for the suggestion.
Image
Albert Wiersch

Post Reply