Image size not being checked in latest version?

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
CliffWalker
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Sep 09, 2008 9:01 pm

Image size not being checked in latest version?

Post by CliffWalker » Sat Dec 13, 2014 2:40 pm

I have recently installed version 15.0003 and amd using the default settings, but validating doesn't flag incorrect img height and width even if I validate twice using a Full check. This has always worked in the past. I have validator engine flag 117 checked (in fact, all flags are checked). Is there something I now need to set to check this? Thanks.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Image size not being checked in latest version?

Post by Albert Wiersch » Sat Dec 13, 2014 2:56 pm

Hello,

Because CSE HTML Validator does not actually download images using http and https, determining the actual image size only works when the image files are local. Is CSE HTML Validator treating this image as a local file or as an http or https file? If http or https, then this check is not performed.
Image
Albert Wiersch

CliffWalker
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Sep 09, 2008 9:01 pm

Re: Image size not being checked in latest version?

Post by CliffWalker » Sun Dec 14, 2014 12:47 pm

Albert,

Thank you for your reply. All files are local to my computer, as they have always been in the past when this worked. I have changed content to HTML 5, but that is the only change besides the new version of Validator. Here's a typical line of code that Validator used to flag in the past:

<a href="Navajo-Horses.html"><img src="rock-art-images/IMGP8316.jpg" height="569" width="900" alt="Rock Art Image" /></a>

I can change the height and width values and the updates are reflected in the image size when the page is previewed. If I rename the image file (IMGP8316.jpg to xIMGP8316.jpg) Validator doesn't complain when I check the page, even if I check it twice or more. But when I preview the page the image is not displayed. It appears Validator is not looking at the image at all even though it is local.

Thanks.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Image size not being checked in latest version?

Post by Albert Wiersch » Sun Dec 14, 2014 4:04 pm

Hello,

If you rename the file, then you may need to reset the link cache to detect that the image is no longer there. The easiest way to do this is to restart CSE HTML Validator but you can also go to the Links tab in the Results Window and click on the settings icon on the left to open the Validator Engine Options in the Link Checking page. Then click Reset Link Cache... otherwise it remembers that the link was checked as "good" even if you rename it.

I will verify that the image size message is still working as it should on Monday. If it is, then I would request that you provide a small sample document and image that reproduces the problem... but let me do a quick test over here first and post back.
Image
Albert Wiersch

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3412
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Image size not being checked in latest version?

Post by Albert Wiersch » Mon Dec 15, 2014 5:18 pm

Hello,

I researched this today and did find a bug in v15. It will be fixed in the next update. If you'd like to try a pre-release version then please send me a private message or email me.

I'm sorry for the bug/trouble.
Image
Albert Wiersch

CliffWalker
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Sep 09, 2008 9:01 pm

Re: Image size not being checked in latest version?

Post by CliffWalker » Mon Dec 15, 2014 5:52 pm

Thanks, Albert. It's a minor issue for me so I'll wait until the next version.

Post Reply