Error: "$" is undefined

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
MBaas
Rank I - Novice
Rank I - Novice
Posts: 11
Joined: Thu Feb 11, 2016 7:31 am

Error: "$" is undefined

Post by MBaas » Wed Jun 15, 2016 4:52 am

I am trying to validate the page with "Open from web" http://miserver.dyalog.com/Examples/SF/ ... ple.mipage (as an example) and am getting an error about $ being undefined. Usually this indicates that jQuery has not been loaded - and the result looks like that.
But any "normal browser" renders this page w/o complaints, so I wonder if I am missing any special config-settings or switches???

Besides, when answering "No" to the prompt about further execution of scripts for this page, that error-message is repeated over and over again (as there are more $ in the file) - doesn't seem logical. Am I being ignored? ;-)

P.S: using 16.0403 (Pro)

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3237
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Error: "$" is undefined

Post by Albert Wiersch » Thu Jun 16, 2016 6:15 pm

Hello Michael,

I assume you are getting this message from the integrated web browser? The integrated web browser doesn't work well in 'Preview Mode' with complex pages that load scripts when using 'Open from the Web'. However, please try switching the integrated web browser to 'Browse Mode' and putting the URL in the URL bar instead then click 'Go'. This should work better than using 'Open from the Web' and then previewing the page in the integrated web browser in 'Preview Mode'.

In 'Browse Mode' (as opposed to 'Preview Mode') the integrated web browser should act more like a real web browser.
Image
Albert Wiersch

MBaas
Rank I - Novice
Rank I - Novice
Posts: 11
Joined: Thu Feb 11, 2016 7:31 am

Re: Error: "$" is undefined

Post by MBaas » Fri Jun 17, 2016 2:08 am

Ok, I see - browsing that page directly and validating WB Source works much better. Thanks!

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3237
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Error: "$" is undefined

Post by Albert Wiersch » Fri Jun 17, 2016 8:51 am

Great! You're welcome and I'm glad that helps. :D
Image
Albert Wiersch

Post Reply