Selecting text in the editor

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 550
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Selecting text in the editor

Post by RSteinwand » Fri Nov 04, 2016 11:47 am

Hi Albert,

I was noticing this today while editing an email stylesheet. When I double-click "000" in the color statement below to paste in a new color...

Code: Select all

body{margin:0;color:#000;background:#fff;font-family:Arial,'DejaVu Sans','Liberation Sans',Freesans,sans-serif;font-size:11px !important}
... what gets highlighted is "color:#000". If I use Dreamweaver or Notepad++ and doubleclick the color, just the "000" is highlighted.

It'd be nice if CSE's editor would work like other ones. Seems to me you fixed something similar to this before by defining delimiters.

Also, when I double click "nowrap" on this statement...

Code: Select all

.nowrap{white-space:nowrap}
... "space:nowrap" is highlighted, instead of just "nowrap".

So it appears that # and : need to be added to the delimiters.

Thanks.
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3221
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Selecting text in the editor

Post by Albert Wiersch » Fri Nov 04, 2016 1:33 pm

Hi Rick,

By default, ':' should be one of the delimiters. However, you may be using older defaults.

Please try going to 'Options->Editor Options' and then the 'Files->File Types' options page. Double-click on the CSS filetype and make sure ':' and '#' are delimiters. You might want to do the same for HTML and maybe some other file types.

Does this fix the issue?

I will also add '#' to the default delimiters for v17.
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 550
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Selecting text in the editor

Post by RSteinwand » Fri Nov 04, 2016 2:01 pm

Thanks. I knew it was easy and checked all over and although I looked at that page, didn't think to double click css.

This is what I had for css:

{}+-*()=,;><$[]^|'"

I also added it to html and php.
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3221
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Selecting text in the editor

Post by Albert Wiersch » Fri Nov 04, 2016 2:18 pm

Great. I assumed that fixed this issue?

By the way, the default delimiters for v17 will be:

Code: Select all

!{}+-*()=,:;><$[]^|'"#
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 550
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Selecting text in the editor

Post by RSteinwand » Mon Nov 07, 2016 12:17 pm

Yes it did.

By "default", do you mean for all file types?

Under what circumstances will my changes be overwritten with the latest?
Rick

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3221
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Selecting text in the editor

Post by Albert Wiersch » Mon Nov 07, 2016 1:05 pm

RSteinwand wrote:Yes it did.
Great!
RSteinwand wrote:By "default", do you mean for all file types?
Yes, it will be the new default for all file types.
RSteinwand wrote:Under what circumstances will my changes be overwritten with the latest?
Generally new defaults (including the delimiters) do not take effect if you already have a setting on your computer. It will keep using the pre-existing setting in order to avoid making any unexpected or undesirable changes.
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 550
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Selecting text in the editor

Post by RSteinwand » Mon Nov 07, 2016 1:34 pm

Ok.

I updated all file types with your version.

Thanks.
Rick

Post Reply