Page 1 of 1

Old browser support.

Posted: Fri Oct 06, 2017 1:30 pm
by RSteinwand
Hi Albert.

I saw this message today:
[605] The "border-bottom-right-radius" property is a CSS3 property but not a CSS1 or CSS 2.1 property. Some browsers (especially older ones) may not support this property, or may have only partial support for it, or may require a vendor prefix (like -moz- or -webkit-).
... which makes me wonder if I care at all about CSS1. It appears to me that most of CSS3 is supported by IE9, which is the oldest version of IE that can access our website after we started blocking everything except TLS1.2. So I probably could ignore all CSS1 messages and probably most of 2.1 as well. (Is there anything between 1 and 2.1 that I can also ignore?) :D

I know you also don't care about old IE for your website.

It'd be nice to have a checkbox to disable certain messages for old browsers. But I suspect you're going to tell me that disabling a certain message number will do the same thing.

Re: Old browser support.

Posted: Fri Oct 06, 2017 2:50 pm
by RSteinwand
I see I had a similar request here: viewtopic.php?f=1&t=2592

Re: Old browser support.

Posted: Fri Oct 06, 2017 4:40 pm
by Albert Wiersch
RSteinwand wrote:
Fri Oct 06, 2017 1:30 pm
It'd be nice to have a checkbox to disable certain messages for old browsers. But I suspect you're going to tell me that disabling a certain message number will do the same thing.
Yep! Disabling flag 605 in the Validator Engine Options will disable that message and a bunch of others about new CSS3 properties.

I should go over those flag 605 messages and do some updating for v18... probably "relegating" some of them to "legacy" messages that won't display unless legacy messages are enabled... and some should probably be warnings because the properties have been removed from CSS3.

I'll put it on my to-do list!

Re: Old browser support.

Posted: Fri Oct 06, 2017 4:51 pm
by RSteinwand
Sounds like a good plan.

Thanks Albert!

Re: Old browser support.

Posted: Fri Oct 20, 2017 8:12 am
by Albert Wiersch
It took me longer than expected but there was more too do than I expected. I have updated the flag 605 messages and added a new flag 615. Flags 605 and 606 now default to unchecked because the properties for those flags are widely supported and it doesn't make sense to generate messages about them anymore. Some messages were removed from flag control and changed to warnings because the properties were dropped from the specification and/or should be avoided.

All of these updates and changes will be in CSS HTML Validator v18/2018.

Re: Old browser support.

Posted: Fri Oct 20, 2017 2:34 pm
by RSteinwand
Cool!

Thanks Albert.