Page 1 of 1

Editor v.190011 (Std) - Help File

Posted: Mon Jan 21, 2019 2:00 pm
by Nigel Blakey
I have just installed v.190011 and find that when I click on the toolbar Help > Ctrl+F1 I get an error dialogue box saying that the help file cannot be found. The file it is looking for is
C:\Program Files\HTMLValidator190\Docum...:\getting started.htm
However, when I open the ...\Documentation folder I find a file called CSSHTMLValidator.chm, and when I open that the Help system opens as expected. I have created a shortcut to the .chm file but it would be awfully good if the Help > Ctrl+F1 link worked properly.
Thank you.

Re: Editor v.190011 (Std) - Help File

Posted: Mon Jan 21, 2019 2:25 pm
by Lou
Nigel, based on you post I checked and noticed there is a newer update 19.0012 now available.
I downloaded the new version and it works correctly.

Re: Editor v.190011 (Std) - Help File

Posted: Mon Jan 21, 2019 2:48 pm
by Nigel Blakey
Lou,
Thank you for coming back so quickly.
On the Current Versions list v.190012 looks as though it was released today but only in the Enterprise edition. Pro and Standard editions look as though they are still on v.190011, so I'll hang on till v.190012 is released for the Standard edition.
Thanks.

Re: Editor v.190011 (Std) - Help File

Posted: Mon Jan 21, 2019 3:26 pm
by Albert Wiersch
Hello,

I'm sorry for the trouble. If you re-download the program then you should get v19.0012 even if the 'Check for Updates' feature does not mention that minor update yet. I would start by installing the update and see if that fixes the problem. If not then please let me know.

Re: Editor v.190011 (Std) - Help File

Posted: Tue Jan 22, 2019 4:13 am
by ReneK
Don't know if it's worth thinking about, but that's what I observed: When selecting "About CSS HTML Validator", it correctly says that I've v19.0011 installed. When checking for updates afterwards, it says that the latest version is already installed, which is v19.0012, but v19.0012 clearly isn't installed yet.

Re: Editor v.190011 (Std) - Help File

Posted: Tue Jan 22, 2019 8:34 am
by Albert Wiersch
ReneK wrote:
Tue Jan 22, 2019 4:13 am
Don't know if it's worth thinking about, but that's what I observed: When selecting "About CSS HTML Validator", it correctly says that I've v19.0011 installed. When checking for updates afterwards, it says that the latest version is already installed, which is v19.0012, but v19.0012 clearly isn't installed yet.
Thanks. I fixed this confusion. This issue happens when I want to release very minor updates but not "advertise" them yet which means the 'Check for Updates' feature won't detect them. Eventually when there are enough updates or an "important" update then I will make the 'Check for Updates' feature detect it. I don't want users to have to frequently update more than is necessary because I think that it's wasteful and unnecessarily time-consuming... and people already deal with enough updates these days (at least I do!).

So the update check feature should now say the latest version is v19.0011 even though you'll get v19.0012 if you were to download it right now. There was a significant fix in 19.0011 so that is what it's going by right now (except for the enterprise edition which will detect v19.0012 when doing a 'Check for Updates').

Re: Editor v.190011 (Std) - Help File

Posted: Tue Jan 22, 2019 9:15 am
by ReneK
Albert Wiersch wrote:
Tue Jan 22, 2019 8:34 am
So the update check feature should now say the latest version is v19.0011 even though you'll get v19.0012 if you were to download it right now.
It does. :)

Re: Editor v.190011 (Std) - Help File

Posted: Wed Jan 23, 2019 5:08 am
by Nigel Blakey
Thank you for your replies on this topic. I have downloaded css-html-validator-190012std-x64-setup.exe as you suggested from the Downloads for Registered Users page, but when I tried to open it my Avast! Antivirus program warned that it might be a dangerous file and submitted it to their automatic testing system (sorry, that was automatic and a little beyond me). However, I persisted in trying to open the file and received an error dialogue box saying, "You may not have the appropriate permissions to access the file." So, I'm a bit stuck.

Re: Editor v.190011 (Std) - Help File

Posted: Wed Jan 23, 2019 9:17 am
by Albert Wiersch
Hi Nigel,

I ran the file through virustotal.com and it came back all clean (0/70). I don't know why Avast is complaining... maybe because it hasn't seen the file before and is being over-protective.

Maybe Avast did something to it so you couldn't run it. Sometimes I think anti-virus programs are like viruses themselves... preventing you from doing what you want to do on your own computer. :) Personally I don't use anti-virus. If there is a questionable file I run it through virustotal.com before running it on my computer.

Or maybe you got a corrupt or incomplete download.

I would try downloading the file again, maybe using a different browser. Avast might do the same thing again though but it's worth a try.

Re: Editor v.190011 (Std) - Help File

Posted: Wed Jan 23, 2019 11:17 am
by Nigel Blakey
Albert,
I downloaded the file again using a different browser. Avast persisted but then declared that the file was clean and the installation proceeded without futher intervention from me. The link to the help file is now fine.
Thank you for your help.
Nigel

Re: Editor v.190011 (Std) - Help File

Posted: Wed Jan 23, 2019 12:31 pm
by Albert Wiersch
Nigel,

Great! I'm glad it's working now and that Avast found that it was clean.