Sweeper misplacing hover class

Post anything about TopStyle here. NOTE: TopStyle has been discontinued.

Moderator: TopStyle Support

Post Reply
denver27
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Mon Dec 03, 2007 2:26 pm

Sweeper misplacing hover class

Post by denver27 » Mon Jan 03, 2011 10:34 pm

a:hover MUST come after a:link and a:visited

When running the Sweeper under version 4.0.0.83 that a:hover precedes a:link and thus a:hover fails to behave as expected.

I work for a designer who has dozens of A classes, so it I sweep any of his messy style sheets then I have to manually relocate the hover tags. I have tried several different Sweeper configurations and the hover classes are always in the wrong place. Probably a bug in 4.0.0.83.

User avatar
TopStyle Support
Rank VI - Professional
Rank VI - Professional
Posts: 507
Joined: Sat Jun 13, 2009 12:38 pm
Contact:

Re: Sweeper misplacing hover class

Post by TopStyle Support » Fri Feb 11, 2011 8:58 am

I cannot seem to reproduce this problem. My Style Sweeper is sorting my selectors "logically" (Tools > Style Sweeper > Configure Style Sweeper).

I'm guessing your Style Sweeper configuration isn't sorting selectors at all. Please edit your Style Sweeper, and click the "Selectors" tab. Is "selector order" set to "unchanged"? Then this explains why Style Sweeper isn't sorting your selectors.

Whenever your Style Sweeper configuration is sorting selectors by anything other than "unchanged" (the default is "logically", by the way), then your A: pseudo-classes are sorted, and A:HOVER is preceded by A:LINK and A:VISITED

Post Reply