Edit/Replace in Files Does Not Update Open Files

Post anything about TopStyle here. NOTE: TopStyle has been discontinued.

Moderator: TopStyle Support

Post Reply
mesquite
Rank I - Novice
Rank I - Novice
Posts: 14
Joined: Mon Aug 13, 2012 12:34 pm

Edit/Replace in Files Does Not Update Open Files

Post by mesquite » Sun Aug 19, 2012 8:55 am

TopStyle version 4.0.0.92
When I do an Edit/Replace in Files using the Replace option, only closed files in the folder get updated. The Find works on open files, but they are not updated.

User avatar
TopStyle Support
Rank VI - Professional
Rank VI - Professional
Posts: 507
Joined: Sat Jun 13, 2009 12:38 pm
Contact:

Re: Edit/Replace in Files Does Not Update Open Files

Post by TopStyle Support » Mon Aug 20, 2012 3:42 am

When Find/Replace in Files has modified a file that is open, TopStyle tells me this:

"this document has been modified since you last saved it. do you wish to reload it?"

are you not seeing this?

By the way: have you tried to perform Find/Replace in Files on "all open files"?

mesquite
Rank I - Novice
Rank I - Novice
Posts: 14
Joined: Mon Aug 13, 2012 12:34 pm

Re: Edit/Replace in Files Does Not Update Open Files

Post by mesquite » Mon Aug 20, 2012 6:04 pm

I do not see the message "this document has been modified ..."
I do not understand what you mean by "all open files" because I do not see that phrase anywhere in the Find/Replace window.

User avatar
TopStyle Support
Rank VI - Professional
Rank VI - Professional
Posts: 507
Joined: Sat Jun 13, 2009 12:38 pm
Contact:

Re: Edit/Replace in Files Does Not Update Open Files

Post by TopStyle Support » Tue Aug 21, 2012 8:48 am

mesquite wrote:I do not see the message "this document has been modified ..."
Is this setting enabled? Options (F8) > General > "ask to reload files modified outside of TopStyle"
mesquite wrote:I do not understand what you mean by "all open files" because I do not see that phrase anywhere in the Find/Replace window.
When you open the Find/Replace window, there's an option that reads: Search "in this folder". When you click on this, you can change "in this folder" to "all open files" (among other options).

Post Reply