Lint warning: missing semicolon

For topics about current BETA or future releases, including feature requests.
Post Reply
User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Lint warning: missing semicolon

Post by RSteinwand » Tue Jun 10, 2008 1:09 pm

Is that for real?

So I need a semicolon at the end of a line terminated with a brace? :?

...onmouseover=function(){ms.hideCurrent();}}

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3415
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Tue Jun 10, 2008 2:21 pm

I doubt you need one... but it may be considered good style by the JavaScript linter and thus it is telling you about it.

Can you right-click on that message and disable it? If not, then I can probably add that feature for that message... just send me some sample code that I can use to reproduce the exact message. Thanks.
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 600
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Post by RSteinwand » Tue Jun 10, 2008 2:58 pm

There is no option to disable lint messages.

<script type="text/javascript">alert('hi')</script>

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3415
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Tue Jun 10, 2008 3:57 pm

Thanks. I've now added the ability to disable just that lint warning - "lint warning: missing semicolon".

You can turn off JavaScript linting completely or just lint warnings. These options are in the JavaScript tab of the Validator Engine Options.
Image
Albert Wiersch

Post Reply