editor not responsive enough

For topics about current BETA or future releases, including feature requests.
Post Reply
User avatar
roedygr
Rank V - Professional
Rank V - Professional
Posts: 370
Joined: Fri Feb 17, 2006 5:22 am
Location: Victoria BC Canada
Contact:

editor not responsive enough

Post by roedygr » Tue Jun 24, 2008 9:11 am

Try making some simple edits to this document:

http://mindprod.com/deepthoughts/musings.html

It is an unusually large document, 200K bytes, I grant you, but the editor becomes unusably slow.

I think the problem is you might be maintaining the document internally in the HTMLValidator editor as a giant Unicode string rather than a tree as is traditional for WP applications. Every time I hit a key, I suspect you must shift hundreds of thousands of bytes of information one slot right.

I have a quite new dual CPU motherboard. I have not seen this sort of jerkiness since the early days of the XT and MSWord version 1.0.

To fix this might require a major rethink of your internal document model, but the advantage would be in the editor would become really snappy for all documents.

Another thought is to have a dual model -- what is visible and what is not, and update your invisible part separately, the way you do now, but update in the background on a separate thread so the the screen feedback is not delayed.

I suspect you might tell me that I deserve dreadful response for the sin of creating such a huge document. That particular document could be easily split, but others I have cannot, such as 400K colour swatch tables:

http://mindprod.com/jgloss/x11alpha.html

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 597
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Post by RSteinwand » Tue Jun 24, 2008 11:55 am

You've seen the stats.... if people can find what they're looking for in x-seconds, they move onto the next Google link. Every recommendation I've seen says to keep the page length to a minimum (like this random source for instance).

I think the problem is the designer, not the editor. :wink:

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3397
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Tue Jun 24, 2008 2:05 pm

I've also noticed the editor component is slower than it should be and I have been sent updated editor sources which should significantly improve this in the next BETA.

Of course, watch your page size too. :D
Image
Albert Wiersch

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 597
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Post by RSteinwand » Thu Jun 26, 2008 3:08 pm

I suspect whatever is making the red underlines go nuts is the problem.

View the source for http://mindprod.com/deepthoughts/musings.html in CSE, then pull up Windows Task Manager and find cse90.exe. Move the mouse in CSE and note the CPU usage hits 45% or more and doesn't quit until the CSE window loses focus.

I suspect you could turn off something in the editor to make it more responsive, maybe spell check?

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3397
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Thu Jun 26, 2008 3:26 pm

RSteinwand wrote:I suspect whatever is making the red underlines go nuts is the problem.

View the source for http://mindprod.com/deepthoughts/musings.html in CSE, then pull up Windows Task Manager and find cse90.exe. Move the mouse in CSE and note the CPU usage hits 45% or more and doesn't quit until the CSE window loses focus.

I suspect you could turn off something in the editor to make it more responsive, maybe spell check?
Yes, I noticed this (moving the mouse CPU usage) awhile ago and reported it to the editor developer. It should be fixed in BETA 2. I am currently waiting on an editor source update and then I plan to release BETA 2 if there are no major issues. It should help a lot.
Image
Albert Wiersch

Post Reply