Another Edge issue

Post here if your message doesn't fit into another forum but is still about web development. Includes site critiques, web hosting and server questions, helpful software and resources, and more.
Post Reply
User avatar
MikeGale
Rank VI - Professional
Rank VI - Professional
Posts: 703
Joined: Mon Dec 13, 2004 1:50 pm
Location: Tannhauser Gate

Another Edge issue

Post by MikeGale » Sun Sep 06, 2015 10:06 pm

I found something with the "LinkedIn" site today.

Using the Edge browser in Windows 10, some pages rendered badly, failed to render or were slow. Front page looked fine.

I tested on two machines, two people testing. The pages rendered as expected in IE and FF.

Anybody else seeing this?

If so any ideas?

(I reported it to LinkedIn, time will tell whether that gets through to anybody technical.)

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3312
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Another Edge issue

Post by Albert Wiersch » Mon Sep 07, 2015 10:11 am

Hi Mike, I don't use Windows 10 all that much yet and would not use the Edge browser at this time given that it could still not word wrap properly... and the fact that Microsoft seems to be patching Windows 10 daily. :)

I'm still using Chrome as my primary browser and that's still what I use on Windows 10 too.

But I would be curious to hear from anyone using Windows 10's Edge browser on a more regular basis.... is anywhere here doing that? Mike, are you? If so, what has been your overall experience with the Edge browser?
Image
Albert Wiersch

fred8615
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 9
Joined: Fri May 03, 2013 8:49 am
Location: Sorrento, Louisiana

Re: Another Edge issue

Post by fred8615 » Mon Sep 07, 2015 2:48 pm

I'm using it daily. It still needs work (ad blocker; letting you choose where to save downloads; being able to go back multiple pages instead of one at a time; opening multiple tabs at once from Favorites) but I find it otherwise fast, stable, and in some regards better than IE (for whatever that's worth to the reader).

User avatar
MikeGale
Rank VI - Professional
Rank VI - Professional
Posts: 703
Joined: Mon Dec 13, 2004 1:50 pm
Location: Tannhauser Gate

Re: Another Edge issue

Post by MikeGale » Mon Sep 07, 2015 6:40 pm

This issue seems to have gone away. (Several tests over several hours on two machines.)

Given that I tested on a couple of machines against a couple of browsers, it was (presumably) Edge specific.

Maybe different content is generated for different browsers and the pipeline for Edge was borked.

On using Edge:
  1. It's early days so I can't say for sure, yet, how much I'll stick with it.
  2. I deliberately use more than one browser, but it's been getting a lot of use in the last day or two. My guess, yes I will use a lot.
  3. When I showed another person the tools for writing on pages and taking an "image cutting" from within the browser, I could see an inadvertent "sale", happening in front of my eyes. (Given that Edge also works on a site where Firefox fails, that gave it an additional boost.)
  4. On my frequency of browser use. There's a variety of factors. One (that others might not be so aware of) is how much it spies on you. (I find it creepy that somebody is kinda sitting on my shoulder watching everything that I do. That's not freedom or civilised.) Haven't run thorough checks for Edge yet, but I do have all Windows 10 telemetry, that I know of, disabled. Last check I found that Chrome spied more than most and it was compiled in. I use it less often as a result.

User avatar
MikeGale
Rank VI - Professional
Rank VI - Professional
Posts: 703
Joined: Mon Dec 13, 2004 1:50 pm
Location: Tannhauser Gate

Re: Another Edge issue

Post by MikeGale » Wed Sep 23, 2015 4:48 pm

Update on Edge:
  1. On some (rare) pages I get no response, even with repeated requests. (Possibly those pages are generated by code, and the server side mechanism is broken.)
  2. Infrequently it times-out on a get, may be related to issue above.
  3. I'd like to be able to add my own extensions to allow me to do what I want, it doesn't have that capability yet.
  4. It works on some pages that fail on IE 11.
Overall I like what I've seen of the browser and use it often. I hope it gets a usable form of extensibility, that I can code myself, but I'm not holding my breath.

User avatar
Jeffery Hadley
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 2
Joined: Mon Nov 09, 2015 8:30 am

Re: Another Edge issue

Post by Jeffery Hadley » Mon Nov 09, 2015 8:33 am

My concern about Edge is that it seems like a striped down version of Internet Explorer with all the problems baked in from the start.

User avatar
MikeGale
Rank VI - Professional
Rank VI - Professional
Posts: 703
Joined: Mon Dec 13, 2004 1:50 pm
Location: Tannhauser Gate

Re: Another Edge issue

Post by MikeGale » Mon Nov 09, 2015 2:43 pm

No. It's not IE. It's a new code base. They originally intended to bundle an IE / Trident rendering engine with it but dropped that plan.

In my view it was released too early. Performance is a bit too low, features like programmability are not there yet...

I currently find a growing number of sites that haven't been proven with different browsers. Result some are best used in IE, some won't work in IE, the same for FF etc. Bottom line: there is a generation of web developers who are not making cross browser sites so multiple browsers are needed.

This suggests opportunities in a world where there is too much useless content that the search engines joyously serve up to us.

User avatar
RSteinwand
Rank VI - Professional
Rank VI - Professional
Posts: 587
Joined: Mon Jun 09, 2008 2:12 pm
Location: Fargo, ND
Contact:

Re: Another Edge issue

Post by RSteinwand » Tue Apr 05, 2016 6:00 pm

Windows 10 was released too early with the assumption that lots of patches could fix it. I would think Edge had the same problem.
Rick

Post Reply