Site loading speed not updated

Post here if your message doesn't fit into another forum but is still about web development. Includes site critiques, web hosting and server questions, helpful software and resources, and more.
Post Reply
nikon

Site loading speed not updated

Post by nikon » Fri Oct 30, 2015 8:43 pm

Hello,

I used it on htaccess for site loading speed higher:

Code: Select all

Header unset Pragma
FileETag None
Header unset ETag

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType text/html "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 1 month"
</IfModule>
## EXPIRES CACHING ##

<FilesMatch "\\.(js|css|html|htm|php|xml)$">
SetOutputFilter DEFLATE
</FilesMatch>

<IfModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</IfModule>

AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
Currently my site loading speed score is only 66/100. How can i improve my site loading speed? Is there anyone help?

Thanks
Nikon
Last edited by nikon on Sat Oct 31, 2015 12:18 pm, edited 1 time in total.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3231
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Site loading speed not updated

Post by Albert Wiersch » Fri Oct 30, 2015 10:33 pm

Hello,

Have you tried running your website through Google PageSpeed Insights: https://developers.google.com/speed/pagespeed/insights/

What does it point out as "should fix"?
Image
Albert Wiersch

nikon

Re: Site loading speed not updated

Post by nikon » Sat Oct 31, 2015 12:07 am

Yes, I already :
Currently my site loading speed score is only 66/100
For Desktop 66%
For Mobile 54%
I think Google always like higher loading speed site!
my site newagebd.net
Please check and let me know anything...how can i improve site speed????

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3231
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Site loading speed not updated

Post by Albert Wiersch » Sat Oct 31, 2015 9:49 am

Thanks. I ran your site through PageSpeed Insights and it listed several areas you can improve with a "Show how to fix" link. Have you clicked on those links? Google provides some very useful information.

One of them is optimize images. For that I like this site:
https://tinypng.com/

If you have any questions then please post a specific question with as much information as possible.
Image
Albert Wiersch

Post Reply