Can't get PayPal Button to form

Discussion about HTML and XHTML related issues.
Post Reply
Pennie77
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 2
Joined: Fri Nov 21, 2008 11:32 pm
Location: Coralville, IA - USA
Contact:

Can't get PayPal Button to form

Post by Pennie77 » Fri Nov 21, 2008 11:46 pm

I've tried html codes for three buttons from Paypal and none work. There is a message from Tidy Tool that says "<input> propriety "border" is incorrect. I searched an html site for help and couldn't get any. I don't know where to enter the new border as I was going to try "border="1" or something. But, the line Tidy Tool gives me does not have an input statement on it or a border message. So, I don't have a clue where to start. It isn't just about the border, the entire paypal button is not showing.

If anyone can fix or even simpley improve this chunk of html, please do so and email me at http://pengroups@gmail.com

Here is a copy of my PayPal Button html

<table action="https://www.paypal.com/cgi-bin/webscr" method="post">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="1271577">
<table>
<tr><td><input type="hidden" name="on0" value="Save Your Marriage Now Just $13.00!"</td></tr><tr><td><input type="text" name="os0" maxlength="60"><</tr>
</td></table>
<input type="image" src="https://www.paypal.com/en_US/i/btn/btn_buynowCC_LG.gif" border="0" name="submit" alt="2">
<img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1">"Buy Now!"
</table>

Please someone help me! Pennie77
Pennie Fries
New to Internet Marketing!

User avatar
MikeGale
Rank VI - Professional
Rank VI - Professional
Posts: 704
Joined: Mon Dec 13, 2004 1:50 pm
Location: Tannhauser Gate

Post by MikeGale » Sun Nov 23, 2008 2:25 pm

I don't know where your markup came from but it's seriously different from what the PayPal generator makes.

If you put the form tags back in you'll get something like:

Code: Select all

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
<input type="hidden" name="cmd" value="_s-xclick" />
<input type="hidden" name="hosted_button_id" value="1271577" />
<table>
<tr><td><input type="hidden" name="on0" value="Save Your Marriage Now Just $13.00!" /></td></tr><tr><td><input type="text" name="os0" maxlength="60" /></td></tr>
</table>
<input type="image" src="https://www.paypal.com/en_US/i/btn/btn_buynowCC_LG.gif" name="submit" alt="2" />
<img alt="" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />"Buy Now!"
</form>
Which does work. One of those td tr's was nested wrong too.

CSE should identify the wrong nesting but can't identify the missing form element.

The border is a long standing error in the PayPal generator (as far as I can see, it may have fixed something with older browsers, I haven't investigated). You can experiment with it, to satisfy yourself, but I don't think it'll make any difference.

In your table markup you have a table cell containing a hidden input. I'm not sure why you're doing that, this may be only part of something more complex, it looks unnecessary in this sample.

Post Reply