Set browser version level

Post here if your topic is about CSS HTML Validator but doesn't fit in another forum.
Post Reply
armplinker
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 6
Joined: Mon Oct 08, 2012 9:48 am

Set browser version level

Post by armplinker » Mon Oct 22, 2018 9:17 am

Is there a way to tell CSS HTML Validator to run the internal IE browser engine at a particular version level or compatibility mode? For example, configure the internal browser to run as IE9 (OMG) and report problems for that level, and then run as IE10, IE11, and Edge and report anything that emerges for that level? I could not see a setting for this. :?:

Also, can it switch to other browsers?

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3359
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Set browser version level

Post by Albert Wiersch » Mon Oct 22, 2018 9:29 am

Sorry, it can't do that. :(

You can use Alt+F8 to open the document in the default viewer for that document type. If it's a web page then you can copy and paste the URL into any other browsers that you want to check.

You can use File->Copy File Path to Clipboard to copy the document location to the clipboard so you can paste it somewhere (like in the browser that you want to test).

If you're concerned about legacy browsers (like IE10 and below) then you might want to enable legacy messages. You can do this by unchecking validator flag 114 in the Validator Engine Options in the Validator Engine->Flags page.
Image
Albert Wiersch

Post Reply