Page 1 of 1

Using jenkins

Posted: Sun Oct 26, 2014 4:54 pm
by Modist
Hi,

Im trying to use the validator together with Jenkins - and have some issues. We're using the Registered version of PRO

the following command work when executed in a command-window - but does not have an effect when run through Jenkins in a buildscript. I have tried enabling the log - and there are no new log-entries when calling it from Jenkins.

COMMAND:
"C:\Program Files (x86)\HTMLValidator\cmdlineprocessor.exe" -veofile "c:\tmp\responsiveemail.veo" "c:\tmp\default.html" -msgwindow "Jwindowname" -x1

any kind of suggestion will be highly appreciated

Kind regards
Morten

Re: Using jenkins

Posted: Sun Oct 26, 2014 4:58 pm
by Albert Wiersch
Hello Morten,

I'm not familiar with Jenkins, but could it be running CSE HTML Validator under a different account? If so, then that will usually affect the settings and registration because it stores and uses different settings based on the user account it is running under.

Re: Using jenkins

Posted: Sun Oct 26, 2014 5:17 pm
by Modist
ah - that makes sense _ will try to login with this user and test

will get back with the result

Re: Using jenkins

Posted: Sun Oct 26, 2014 5:34 pm
by Modist
it worked :-) I thought that when I referred to a veofile it would have the same effect.

btw have you considered supporting generating the output in checkstyle-format ?

If anybody is interested I have made a small c#-parser - I will gladly post the code in this forum if needed.

Re: Using jenkins

Posted: Sun Oct 26, 2014 10:29 pm
by Albert Wiersch
Great! I'm glad that worked.

The veo file only affects most validator engine settings, not everything.

I'm not sure what you mean by "checkstyle-format". Can you be more specific? You should be able to generate the output in almost any format you want using custom user functions, but that requires some coding.

Thanks for your offer on the C# parser! If you think someone might find it helpful then can you post it in the forum in a separate thread?