Find window off screen

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
GnomeyNewt
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Feb 22, 2005 5:42 pm
Location: The stars!

Find window off screen

Post by GnomeyNewt » Tue Feb 22, 2005 5:46 pm

Hello,

Thought I'd try out these new forums before sending in an e-mail. The strangest thing has happened. My "find" window has somehow gone missing from my viewable space. When I was first using it, it kept getting closer and closer to the left. I swear, everytime I opened it to use it, I'd have to drag it from the far left which was half out of viewable area. Now it's just gone. At first I thought I was freezing up the program but if I type "anyting" and hit enter it will say "didn't find" or I can hit ESC and it will exit out of find. So I know its still around! I've changed my screen res and I've reinstalled. I was thinking it would probally work if I just did a new install, but how do I save my settings?

Anybody have any idea how to get it back into my viewable area?
Sarah :c)

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3451
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Tue Feb 22, 2005 7:45 pm

Hi Sarah,

Sorry, I'm not sure what's happening. What version of CSE are you using? If a version prior to 6.0, then you might want to try this (regfix.reg):
http://www.htmlvalidator.com/htmlval/htmlvalqa.html#q24

Exit CSE, then open/run regfix.reg and reload CSE. Hope this helps. Let me know if not.
Image
Albert Wiersch

GnomeyNewt
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Feb 22, 2005 5:42 pm
Location: The stars!

Post by GnomeyNewt » Sat Feb 26, 2005 9:29 pm

Hello Again,

The version I am using is v6.53. The problem is that when I try to use the Find or the Find & Replace option, the screen does not pop up. But I cannot use the editor until I hit ESC. At first I thought it was just freezing up, but its just the find option thats messed up.

I tried to uninstall and reinstall the program and its still a problem. I really would like to use this option. Right now I am opening up my files into my text editor because I can't use the find/replace option with HTML Val.

Should I still try to use the regfix thing?
Sarah :c)

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3451
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Mon Feb 28, 2005 12:08 pm

Hello,

You can try to do the regfix.reg fix but I don't think it will help. It seems that unloading and reloading CSE HTML Validator still doesn't help. I wonder if it could be a problem with your video drivers that is somehow causing the dialog box to miscalculate where it should open. Have you checked to see if you are running the latest video drivers for your video card? I will see if I can make any changes to v7.00 BETA that would help prevent this problem.
Image
Albert Wiersch

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3451
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Wed Mar 02, 2005 12:23 pm

Sarah,

In v7.0 BETA 2 (to be released soon), I've added additional code to help prevent certain dialogs, including the find dialog, from opening off screen. If you can and want, please try this BETA and let me know if it fixes the problem for you. It should be available soon, possibly today. Sorry for the trouble!
Image
Albert Wiersch

ewoutdegraaf
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 1
Joined: Tue Apr 19, 2005 7:57 am

Post by ewoutdegraaf » Tue Apr 19, 2005 8:01 am

I have the same problem with version 6.52 lite
The find window is somewhere above my screen and the only way to get it back is Alt-Space, then down arrow to the 'move' option. I can then use the cursor keys to get it back on the screen. It will stay there for that editor session, but as soon as i close down and restart validator, the problem is back.

When i use Ctrl-F several times within one session, the find screen moves up slowly. Sometimes it does not move up, sometimes it does. But with ctrl-F several times after each other, it definately moves up...

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3451
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Post by Albert Wiersch » Tue Apr 19, 2005 10:48 am

Thanks for the report. I can't reproduce this on my system but I've added some code that should help with this problem. It is in the current v7.0 Pro BETA and will be in the next lite edition as well. It should keep the window from opening too far up or to the left.
Image
Albert Wiersch

ripley
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 1
Joined: Wed Apr 27, 2005 1:48 pm
Location: Seattle
Contact:

Missing search/find message box

Post by ripley » Wed Apr 27, 2005 2:01 pm

Hi, I've been using the 6.5220 lite for about a week and am quite pleased, except as others have reported, the search/find dialog box has gone missing. Since this is a crucial part of editing, it needs to be working.

How can I get the beta v7.0 fix you described? It looks like it is for v7pro registered users only.

Thanks,

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3451
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Missing search/find message box

Post by Albert Wiersch » Wed Apr 27, 2005 2:28 pm

ripley wrote:How can I get the beta v7.0 fix you described? It looks like it is for v7pro registered users only.
Hello,

You're correct. v7.0 BETA is only for registered/licensed v7.0 pro users at this time. In late June (when v7.0 is released) a standard edition will be available and the lite edition will probably be available sometime in July.
Image
Albert Wiersch

GnomeyNewt
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Tue Feb 22, 2005 5:42 pm
Location: The stars!

Post by GnomeyNewt » Thu Jun 23, 2005 10:09 pm

Hiyahs,

Sorry I totally forgot about this issue! Sometimes that happens when you have a 14 month old running around :c). Anyhows, glad to hear I wasn't the only one as I thought I might be going a little nutso maybe not enough sleep and seeing things. But also glad to hear it is fixed in the newer version. YEY a new version. Thanks for keeping up with the program and I hope to see many more updates! :c)
Sarah :c)

Post Reply