'Missing space character' error??

Discussion about HTML and XHTML related issues.
Post Reply
Bluenose
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Sun Jan 19, 2014 2:18 am

'Missing space character' error??

Post by Bluenose » Sun Jan 19, 2014 2:24 am

Hello

My CSE HTML validator is giving me the following error
Error in line 169 at character 55: Is there a missing space character? A quoted string (like an attribute value) cannot be immediately followed by text. It must be followed by a space or by the end of the tag.


related to this line in my code:

Code: Select all

<object data="BengalTiger.pdf"type="application/x-pdf"width="500" height="400">
This line fits in here in my code:

Code: Select all

<object data="BengalTiger.pdf"type="application/x-pdf"width="500" height="400">

<p>Please download our menu from <a href="BengalTiger.pdf">here</a></p></object>
What am I doing wrong, please?

Thank you.

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3453
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: 'Missing space character' error??

Post by Albert Wiersch » Sun Jan 19, 2014 6:30 pm

Hello,

There should be spaces before the "type" and "width" attributes, like this:

Code: Select all

<object data="BengalTiger.pdf" type="application/x-pdf" width="500" height="400">
Image
Albert Wiersch

Bluenose
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 3
Joined: Sun Jan 19, 2014 2:18 am

Re: 'Missing space character' error??

Post by Bluenose » Mon Jan 20, 2014 12:52 pm

Hello

Oh, yes, I see what you mean!

Many thanks for pointing that out - the error have gone now.

Cheers!

Bluenose

Post Reply