...encoding declaration appears to be after the first 1024

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
User avatar
anv2010
Rank II - Novice
Rank II - Novice
Posts: 34
Joined: Wed May 05, 2010 4:41 pm
Contact:

...encoding declaration appears to be after the first 1024

Post by anv2010 »

Hello,

The CSE HTML Validator issues the following message erroneously, in my opinion:

Code: Select all

Error in line 1 at character 79: This character encoding declaration appears to be after the first 1024 bytes of the document. The element that contains the encoding declaration should be moved closer to the top of the document so that it's completely within the first 1024 bytes of the document.
This is the beginning of the HTML page itself:

Code: Select all

<!DOCTYPE html><html lang="en"><head><title>Unit measurement online conversions, calculations and formulas</title><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
I believe, that the error is issued due to the fact, that my HTML page does not have any new line characters.

Albert, could you please take a look?

Thank you!
Conversions and Calculations
https://www.aqua-calc.com

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3478
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: ...encoding declaration appears to be after the first 10

Post by Albert Wiersch »

I think this has already been fixed for the next update.

Thank you & sorry for the trouble.

User avatar
anv2010
Rank II - Novice
Rank II - Novice
Posts: 34
Joined: Wed May 05, 2010 4:41 pm
Contact:

Re: ...encoding declaration appears to be after the first 10

Post by anv2010 »

When do you plan to make the update available?

Thank you!
Conversions and Calculations
https://www.aqua-calc.com

User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3478
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: ...encoding declaration appears to be after the first 10

Post by Albert Wiersch »

anv2010 wrote:When do you plan to make the update available?
Great. I hope to have the next update out in early or mid January.

If you want a pre-release build before then, then please send me a PM and I'll get one to you.

UPDATE: v14.01 is now available which includes a fix for this.

Post Reply