Stalled Link checking and valid links reported as Bad

For technical support for all editions of CSS HTML Validator. Includes bug reports.
Post Reply
User avatar
toonr
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 4
Joined: Wed Jun 14, 2017 8:48 am

Stalled Link checking and valid links reported as Bad

Post by toonr »

Hello,
Have been running into issues when running a batch wizard job where the link check process seems to stall, typically between 30-40% complete.
If I run Fiddler, and then run the batch wizard job, the link check process completes, but I did receive 2 prompts from Fiddler regarding Certificate Errors. Perhaps these Certificate Errors are the reason for the paused link check process?

With the completed reports, so many links that are reported as bad do in fact work when checked manually - this substantially diminishes the value of the link report.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

Hello,

I'm sorry for the trouble.

CSS HTML Validator doesn't do certificate checking so I don't think that's the issue but I would be interested in seeing the exact prompt that Fiddler is giving you.

The web server might be reporting the links as bad to CSS HTML Validator for some reason. Can you reproduce this on a public web server so I can try to reproduce the problems here? Also, can you open the reported "bad links" in CSS HTML Validator using "File > Open from the Web"?

Finally, can you provide a link report with the details of the bad links? I'd like to see what server error code is being reported for the reported bad links.

This issue may be hard to track down without more detailed information or a way I can reproduce it here.
User avatar
toonr
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 4
Joined: Wed Jun 14, 2017 8:48 am

Re: Stalled Link checking and valid links reported as Bad

Post by toonr »

Hi Albert,
Looks like links were reported as bad primarily due to redirects (some http to https, and others)
The validation was performed against our public website at https://www.wd-deo.gc.ca
Link to one page of the report, showing some of the errors: https://www.wd-deo.gc.ca/vid/validation/default2.html
I was only able to complete the report by having Fiddler running, and then launching CSE HTML Validator batch wizard.
Without it running, the batch wizard seemed to stall around 1/3 of the way through link checking.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

Hello,

Thank you! I will investigate this in depth next week and get back to you.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

Hello,

I wanted to give an update on this.

First, I will have the program ignore common values for the "vocab" attribute (like http://schema.org/) so there won't be warnings in the link reports for these values.

More importantly, I was able to reproduce an issue that I think is causing the link checker to stall. I am currently trying to figure out why this is happening and implement a fix.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

Just another update on this, I'm still waiting to hear back from the developers who are better able to understand what's happening. I hope they will provide some assistance soon.

I am also back from a family visit and will look more into this soon. It is still on my mind as the link checker should not stall like it's doing and require a program restart to get it working again.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

Hello,

I now have an update for you to try. Please download the latest pro version here:
https://www.htmlvalidator.com/download/registered.php

You should get v21.0150 even though the download page currently says only v21.0100 is available.

Please install it over your current v21.0100 version.

If you want to remove the warnings for redirected links then you can go to the Validator Engine Options (Ctrl+F4) and the Link Checking page. Change the Redirected links option to what you want (like OK).

Please let me know how it works.

UPDATE: I found some issues with the link checker, URL encoding, and redirection, which should be fixed in an update.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

OK, hopefully the last fix. :D

If you download now you should get v21.0151 which fixes some potential issues when the link checker runs into location changes when checking links.
User avatar
toonr
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 4
Joined: Wed Jun 14, 2017 8:48 am

Re: Stalled Link checking and valid links reported as Bad

Post by toonr »

Thank you Albert, just downloading now and will give it a spin!
User avatar
toonr
Rank 0 - Newcomer
Rank 0 - Newcomer
Posts: 4
Joined: Wed Jun 14, 2017 8:48 am

Re: Stalled Link checking and valid links reported as Bad

Post by toonr »

Link checker ran through without issue, and the reported bad links appears to be much more accurate now.
Thank you!
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3604
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Stalled Link checking and valid links reported as Bad

Post by Albert Wiersch »

toonr wrote: Wed Apr 14, 2021 11:30 am Link checker ran through without issue, and the reported bad links appears to be much more accurate now.
Thank you!
Great! I'm happy to hear that and you're very welcome. Thanks again for reporting this issue.
Post Reply