Respect "rel=nofollow"

For technical support for all editions of CSS HTML Validator. Includes bug reports.
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

> As for the discrepancy in the validator/CSS messages, there really shouldn't be any if the validator options are the same.

Maybe it is one of my option. In the validator editor, I got no error and no messages: "Errors only" mode enabled. Showing only error messages (with some exceptions). But when I use Batch Wizard, I got no error but lot of warning messages (so it surprised me) and it said too many messages so it considers as 1 error. So this confuses me since I always think I do not have any error in the URL/page to be validated.

1) So I did not find out yet how to enable warning messages in the editor (disable "Errors only" mode). Where is this option? I expected that if this option is enabled, then the Messages tab would show the number of messages, like Warnings (50).

2) Once enabled, will I see 1 error due to "too many warning messages" as with Batch Wizard? If yes, then it is bad, although this is in sync between editor and Batch Wizard.

Edit (add):
Albert Wiersch wrote: Fri Dec 18, 2020 2:30 pm You only need to validate a file in the editor that causes the message to be generated. You can then disable the message and it will be disabled for the Batch Wizard and for all URLs.
In fact it is a catch22 situation. I do not have any messages in Editor console (right term Result Windows ?) due to "Errors only" mode enabled, so I cannot disable them.

The problem is differences between v20 and v21 for me.
With "Errors only" mode enabled (I still do not know how to disable/enable it), and CSS syntax enabled, and for the same document :

With v20:
- No error (if document OK) in Results Windows.
- No messages (warning or informaiional) in Results Windows. No CSS messages.
- No informational messages (for sure), no CSS messages (for sure) and only warning messages (to check, I did not remember well) with Batch Wizard.

With v21:
- No error (if document OK) in Results Windows.
- No messages (warning or informaiional) in Results Windows. CSS messages present (which is in sync with CSS syntax check option by the way).
- Informational, CSS and warning messages all present with Batch Wizard.

So the other problem is that the Batch Wizard does not follow the "Errors only" mode.
But thanks to this "feature", I discover a lot of interesting information that I would not know since I mainly used the Editor, not the Batch wizard :-).

Edit (add):
OK I got it. The option are in the Editor, menu Options/Validator Engine Options/Set Default Validation Mode/Errors and warnings only.
With this option I got the same messages as with Batch Wizard. For example, tab Errors(1), Warnings(30).

So the problem is that apparently v21 Batch Wizard does not follor the common setting in "Options/Validator Engine Options/Set Default Validation Mode".
In my case, "Options/Validator Engine Options/Set Default Validation Mode" is et to "Errors only", and followed by the Editor.
But Batch wizard seems to follow different setting. Edit: in fact it seems to have finer granular choices than the Editor. So to get no warning messages (equivalent to Editor "Errors only", you have to uncheck the warning message part from Batch wizard/Validator engine options part (Ctrl-F4). This satisfies me since now with 29K+ documents, I don't have to manage the warning messages (30 per document), and then I am in familiar situation as with to v20.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

ktp wrote: Sat Dec 19, 2020 2:04 am > As for the discrepancy in the validator/CSS messages, there really shouldn't be any if the validator options are the same.

Maybe it is one of my option. In the validator editor, I got no error and no messages: "Errors only" mode enabled. Showing only error messages (with some exceptions). But when I use Batch Wizard, I got no error but lot of warning messages (so it surprised me) and it said too many messages so it considers as 1 error. So this confuses me since I always think I do not have any error in the URL/page to be validated.
The message about there being too many warnings is an error message.

If you are seeing warnings in the Batch Wizard but not the editor, then the validation mode may be different. The validation mode for the Batch Wizard is set in the Batch Wizard Options 'Tool to Use' page. You probably have it set to something other than 'Errors only' if you are seeing warnings.

Here's more information on validation modes:
https://www.htmlvalidator.com/current/d ... _modes.htm
ktp wrote: Sat Dec 19, 2020 2:04 am1) So I did not find out yet how to enable warning messages in the editor (disable "Errors only" mode). Where is this option? I expected that if this option is enabled, then the Messages tab would show the number of messages, like Warnings (50).
You can change the editor's default validation mode using the main menu 'Options > Validator Engine Options > Set Default Validation Mode'... or from the toolbar 'Options > Set Default Validation Mode'.

For more information on what tabs show in the Results Window please see the below link. Different validation messages may be shown in different tabs.
https://www.htmlvalidator.com/current/d ... window.htm
ktp wrote: Sat Dec 19, 2020 2:04 am 2) Once enabled, will I see 1 error due to "too many warning messages" as with Batch Wizard? If yes, then it is bad, although this is in sync between editor and Batch Wizard.
If the validation mode of the editor and Batch Wizard are the same, then the validator messages should be identical in most cases so you should see the 'too many warning messages' in the editor as well. As for it being bad, in general, too many warnings are probably bad but it depends on what the messages actually are and perhaps other factors as well (like exactly what you mean by 'bad').
ktp wrote: Sat Dec 19, 2020 2:04 am Edit (add):
Albert Wiersch wrote: Fri Dec 18, 2020 2:30 pm You only need to validate a file in the editor that causes the message to be generated. You can then disable the message and it will be disabled for the Batch Wizard and for all URLs.
In fact it is a catch22 situation. I do not have any messages in Editor console (right term Result Windows ?) due to "Errors only" mode enabled, so I cannot disable them.
It sounds like you'll need to change the validation mode in the editor so that the message you want to disable is generated in the editor. The Results Window is the bottom part of the main window that shows the validator messages. I suppose it's a bit misleading because it's not actually a separate window but the bottom part of the main window.
ktp wrote: Sat Dec 19, 2020 2:04 am Edit (add):
OK I got it. The option are in the Editor, menu Options/Validator Engine Options/Set Default Validation Mode/Errors and warnings only.
With this option I got the same messages as with Batch Wizard. For example, tab Errors(1), Warnings(30).
Great!
ktp wrote: Sat Dec 19, 2020 2:04 am So the problem is that apparently v21 Batch Wizard does not follor the common setting in "Options/Validator Engine Options/Set Default Validation Mode".
In my case, "Options/Validator Engine Options/Set Default Validation Mode" is et to "Errors only", and followed by the Editor.
But Batch wizard seems to follow different setting. Edit: in fact it seems to have finer granular choices than the Editor. So to get no warning messages (equivalent to Editor "Errors only", you have to uncheck the warning message part from Batch wizard/Validator engine options part (Ctrl-F4). This satisfies me since now with 29K+ documents, I don't have to manage the warning messages (30 per document), and then I am in familiar situation as with to v20.
Yes, the Batch Wizard uses the validation mode set in the Batch Wizard Options 'Tool to Use' page and not the validation mode set in the editor.

I hope this helps!
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

ktp wrote: Fri Dec 18, 2020 6:36 am First quick report with v21 version and the user scripts for rel="nofollow" and rel="canonical" provided by admin.

1) I have several CSS Html validator messages at start:
External CSS file "C:\Users\user\AppData\Roaming\AI Internet Solutions\CSS HTML Validator\21\batchreporttemplate.css" cannot be accessed. Does it exist? Falling back to using the internal default CSS instead.
Similar error message for c:\Users\user\AppData\Roaming\AI Internet Solutions\CSS HTML Validator\21\htmlvalV210.cfg. I have to get it from v20 after renaming it.
Hello,

I tried to reproduce this and could not.

Those files should be automatically copied to C:\Users\(user)\AppData\Roaming\AI Internet Solutions\CSS HTML Validator\21 when CSS HTML Validator 2021/v21 is first run.

Have you changed any installation folders or make any changes to the default installation folders for any version of CSS HTML Validator?

Are you running any anti-malware/anti-virus programs? If so, which one(s)?

I'm trying to figure out why you ran into these issues to make sure others won't run into similar issues. Thanks.
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

Hello,

I love portable applications so after installing CSS HTML validator, I copied all the installed directory to my portable one, then uninstall CSS HTML validator. Then I run CSS HTML validator as "portable" application. It seems that CSS HTML Validator is not 100% portable. Is there a cleaner procedure to make CSS HTML validator portable?
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

ktp wrote: Tue Dec 22, 2020 3:17 pm Hello,

I love portable applications so after installing CSS HTML validator, I copied all the installed directory to my portable one, then uninstall CSS HTML validator. Then I run CSS HTML validator as "portable" application. It seems that CSS HTML Validator is not 100% portable. Is there a cleaner procedure to make CSS HTML validator portable?
Hello,

Thank you for the clarification which explains why you ran into issues. Portable mode is indeed a "BETA" feature at this point. I have not worked on it in awhile. The best information about it is here:
viewtopic.php?f=2&t=1134

I am glad you were able to get it updated... however, if you are using the v20 config file with v21 then I would recommend using the updated v21 config file instead (although v21 should be backward compatible with v20 config files).
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

The problem I got probably due to that I do not do a full uninstall of CSS HTML Validator (once the popup asked for full uninstall or not). This time I do full uninstall of previous v21, then install new v21.01, then copy all the installed directories to a clean new portable directory. Then I make a full uninstall of CSS HTML Validator. Then I run the portable version and register it. All seems to be fine now, no error message (missing files, fonts...). Nothing created in Roaming directory, and nothing in Program Files.
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

In fact, the Roaming directory is created (c:\Users\(user)\AppData\Roaming\AI Internet Solutions\CSS HTML Validator\21\). From it, I delete the configuration file htmlvalV210.cfg, and set its location to my portable directory. It seems OK now.

Update: I did not have the empty cseoptions.ini file, so I created it, restart the program. But in Help/About there is no mention of Portable mode.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

ktp wrote: Tue Dec 22, 2020 9:11 pmUpdate: I did not have the empty cseoptions.ini file, so I created it, restart the program. But in Help/About there is no mention of Portable mode.
Hello,

Can you check again? If it's running in portable mode then the 'About' message should say: Running in portable mode from folder "(folder)". If you don't see that then can you send a screenshot of the about box/dialog?

Upgrades can be tricky if you're using portable mode. I do not recommend using portable mode unless it's really necessary (because of the potential issues & complexities with it like the issues you ran into).
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

Here is the screenshot.
Attachments
Validator_about_2020-12-23_062911.jpg
Validator_about_2020-12-23_062911.jpg (64.48 KiB) Viewed 709 times
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

Thank you. That is strange. I can't find a problem/bug in the code.

Can you go to 'Help > Copy Program Info to Clipboard' and then paste in a reply what CSS HTML Validator copies to the clipboard?
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

Data (private) sent with private message.
ktp
Rank II - Novice
Rank II - Novice
Posts: 48
Joined: Sat Oct 29, 2016 10:34 am

Re: Respect "rel=nofollow"

Post by ktp »

Problem resolved, thanks to Admin:
"For v21+, you should use chvoptions.ini instead of cseoptions.ini."

Now in Help/About CSS HTML Validator, the program does indicate that it is running in portable from folder (user portable folder).
No more trace of CHV in Windows Program Files, or in User Roaming directory. The previous non-portable User Roaming data are now located in PortableUserData sub-directory of user portable folder.
User avatar
Albert Wiersch
Site Admin
Site Admin
Posts: 3589
Joined: Sat Dec 11, 2004 9:23 am
Location: Near Dallas, TX
Contact:

Re: Respect "rel=nofollow"

Post by Albert Wiersch »

ktp wrote: Wed Dec 23, 2020 11:37 am Problem resolved, thanks to Admin:
"For v21+, you should use chvoptions.ini instead of cseoptions.ini."

Now in Help/About CSS HTML Validator, the program does indicate that it is running in portable from folder (user portable folder).
No more trace of CHV in Windows Program Files, or in User Roaming directory. The previous non-portable User Roaming data are now located in PortableUserData sub-directory of user portable folder.
Great!

I've updated the forum post about portability mode with the name change to chvoptions.ini in 2021/v21+.
Post Reply