Page 1 of 1

Multi Select Shell navigation in editor

Posted: Fri Jun 13, 2008 6:39 pm
by MikeGale
I tried to use CSE (8.99latest) to carry out a batch edit on a bunch of files. (They are utf-8 encoded and needed some simple replacements.)

I didn't get very far and it cost me some time.

In a "shell" within CSE I went to the directory, selected the files there and tried to open them.

The result was surprising.

A lot of processes were kicked off, attempting to edit the pages. Notepad, Expression Web and plenty of Word. Some of the Word instances were window with topmost title bar only rest blank. The process somehow broke Word which did an "ET phone home" message when I next restarted.

In other words not pleasing.

(I'm not sure why those applications fired, seems a bit odd to me, but I'm not going to research it.)

Is there an easy way of altering that behaviour? (which is presumably based on file associations)

(I may have missed a technique to do what I intended, I just did the natural thing.)

Posted: Mon Jun 16, 2008 10:22 am
by Albert Wiersch
Hi Mike,

Sorry for the inconvenience.

When you do that, the shell will try to open the files with the default program (as if you did it in Windows Explorer). You shouldn't do it that way to open files in the editor. This behavior hasn't changed in V9 and is the same in previous versions.

Instead, try selecting the files and try dragging and dropping them onto the main editor window instead of choosing "Open" from the shell pop-up menu.

I hope this helps.

Posted: Mon Jun 16, 2008 5:51 pm
by MikeGale
Hi Albert,

Thanks for that.

It's not a thing I've tried since looked for a "projects system" in the editor.

I'll try to remember the drag and drop technique.

(My best guess with the word thing is that a word patch installed a couple of days ago must have hijacked a default file association.)

Posted: Mon Jun 16, 2008 6:19 pm
by MikeGale
I had a look at the inbuilt tools for changing file associations.

No wonder I avoid that part of Windows.

What an obstructive UI and then it has major parts missing (like a decent interface for altering the "default Edit command"). With magic parameters in the command line and those four DDE prameters it's not possible to get these commands fixed without extra work.

This must be deliberate, to stop those who would make a mistake from trashing their OS.