CSE HTML Validator includes a powerful but lightweight HTML, XHTML, CSS, and general text editor.

Feature Overview

Block Selection - Block selection mode (when holding down the Alt key) (New v10.0030)

Bookmarks - Easily jump back and forth between bookmarks. Press Shift+Ctrl+# to set a bookmark and Ctrl+# to go to a bookmark. # is any single numeric digit from 0 to 9. You can view the gutter to see where the bookmarks are placed.

Close Tabs - Easily close open document tabs by middle-clicking on the tab. (New v8.00)

Find Matching Tag - Find the matching start or end tag by pressing Ctrl+M. (New v9.00)

Dynamic Help - Easily access help pages for recognized HTML and CSS properties that are near the current editor caret position by pressing F1. (New v10.00)

Convenient Keyboard Shortcuts - Saves you time. Many functions provide keyboard shortcuts, including shortcuts to many tags. See the Shortcut Quick Reference Guide for some time-saving shortcuts.

Repeat Last - Press F4 to repeat the last text insertion or text selection/sort command. (New v12.00)

Edit Multiple Files - Simultaneously edit and open multiple files. Easily select the file to edit using a tab control or, in the standard and higher editions, using the Open Documents Window.

Full Screen Mode - Use to maximize the actual editing window. Quickly toggle full screen mode by pressing F11 or the full screen button.

Go to Line - Quickly go to a line number (and optional character location) by pressing Ctrl+G. Also accessible from Edit->Go to Line.

Gutter Bars - View gutter bars for bookmarks, code folding, and line numbers. Gutter bars can be shown or hidden from the View->Editor->Gutter Bars menu.

Integrated Web Browser - (tick_16Pro, tick_16Std, cross_16Lite) Preview your documents as you edit them or browse the web in the integrated web browser. As you browse the web, HTML Validator can automatically validate the pages. Requires Microsoft Internet Explorer v4 or later.

Line Numbering - View line numbers in front of each new line. This can be turned on or off from the View->Editor->Gutter Bars->Line Numbers menu or from the Editor Toolbar.

Link Checking - (tick_16Pro, tick_16Std, cross_16Lite) HTML Validator extracts a list of links during validation which you can then view and check. HTML Validator supports local file, HTTP, and HTTPS link checking, as well as DNS name checking for various other link types. The link checker is designed for fast performance and works in the background. To view and check the links, select the Links tab in the Results Window. For more information about link checking, please visit the Link Checking section in the Things You Should Know topic.

Main and File Toolbars - Provide quick access to common functions. Show or hide toolbars from the View->Toolbars menu. Large or small icons are available for these toolbars.

Reorder Tabs - Easily reorder open document tabs by dragging and dropping. (New v8.00)

Right Margin Line - View a vertical line at the right margin as a visual reference to help you format your documents. This can be turned on or off from the View menu. The location of the right margin line can be adjusted and word wrapping can optionally wrap at this line instead of at the window width.

Dual Shell Windows - (tick_16Pro, tick_16Std, cross_16Lite) Includes two shell windows to quickly open documents or perform other file operations. Show or hide these windows from the View->Windows menu. The Shell 1 Window can also be shown or hidden using the Editor Toolbar or by pressing Alt+F9. The shell windows can float or be docked.

Results Window - Displays the validation results. Show or hide this window from the View->Windows menu or by pressing F9.

Scratch Pads - (tick_16Pro, tick_16Std, cross_16Lite) Two independent scratch pads that can be automatically loaded when HTML Validator is run and saved at exit. Scratch pads be used as a temporary storage area for cutting and pasting or other use. Available from the Scratch tab in the Results Window.

Editor Toolbar - Provides quick access to common functions. Show or hide this toolbar from the View->Toolbars menu.

Spell Checking - Powerful and fast spell checking with several dictionaries to choose from and a user dictionary to add your own words. Microsoft Word's user dictionary, if available, can also be used.

Split View - A powerful and useful feature of CSE HTML Validator. Edit the same or different document in two separate editing windows. This can be turned on or off from the View->Editor menu or from the Editor Toolbar. The two editing windows in split view can be divided horizontally or vertically.

Status Bar - Displays useful information throughout HTML Validator's use. Show or hide the status bar from the View menu.

Syntax Highlighting - Color syntax highlighting for many file types including HTML, C/C++, Delphi, Java, Perl, SQL, VBScript, and more. This can be turned on or off globally or for individual file types.

Color Inserter - Quickly insert a color in the #RRGGBB format using a visual color picking tool (Alt+I).

Time/Date Inserter - Quickly insert the current time and date into a document with a menu option or the shortcut Ctrl+D.

CSS Inserter - Quickly let HTML Validator type in CSS properties for you. The CSS Inserter is also user configurable.

HTML Inserter - Quickly let HTML Validator type in HTML tags for you. The HTML Inserter is also user configurable.

PHP and JavaScript Inserters - Quickly let HTML Validator type in common PHP and JavaScript strings. This inserter is also user configurable.

User Inserter - Quickly let HTML Validator type in your own custom tags for you (or any text you want). You configure this inserter yourself and changes are not lost when you update or upgrade.

Uncluttered Interface - The user interface is designed to maximize productivity. It is powerful, clean, and easy to use.

Unlimited File Size - No preset limit on the size of files that can be edited.

Unlimited Undo/Redo - No preset limit on the number of undos or redos that can be done. For fast access, press Ctrl+Z to undo and Ctrl+Y to redo.

Word Wrap - Word wrapping can be turned on or off from the Options menu or from the Editor Toolbar. Word wrapping at the right margin line is also possible.

Not all features are listed.