Internet Explorer Options

Make Source Viewer in Internet Explorer - When viewing the source in Internet Explorer, use CSE HTML Validator as the viewer. You will be able to choose whether you want to open the source in CSE HTML Validator's Editor or you want to validate the source with CSE HTML Validator and then display the results in Notepad (unless another viewer has been specified).

Restore Source Viewer in Internet Explorer - Restore the source viewer in Internet Explorer.

Important

Administrator privileges are usually required to make the registry changes needed to change the behavior of View Source in Internet Explorer.

Therefore you may need to 1) re-run CSE HTML Validator with administrator privileges, 2) make the changes using the options documented above, then 3) restart CSE HTML Validator normally for the changes to take effect.

To run CSE HTML Validator with administrator privileges, right-click on CSE HTML Validator's program icon or shortcut and choose 'Run as administrator'.

Tips

In Internet Explorer 8, the source viewer can also be changed in Tools->Developer Tools->File->Customize Internet Explorer View Source.

In Internet Explorer 9, press F12 to open the developer tools and then choose File->Customize Internet Explorer view source to choose the source viewer.

In Internet Explorer 10 and above, use the Windows Registry Editor to make sure that this registry key exists (you may need to create new View Source Editor and Editor Name keys): Computer\HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\View Source Editor\Editor Name, then set the (Default) value for the key to the source viewer's exe file. Visit this Microsoft Community forum post for more information.