Batch Wizard Tips (tick_16 Pro, cross_16 Std, cross_16 Lite)

Using the Batch Wizard (Tools->Batch Wizard or press F2), you can create a list of targets (files, URLs, and folders) and then validate or use a tool on every document in the target list. This is an easy way to validate or process multiple files.

You can also specify a single URL target in the Batch Wizard, then set the target's properties to follow links. In this way, the Batch Wizard can spider an entire website (or part of it) with a single URL.

The Batch Wizard is also great to use when creating dynamic documents such as ASP and PHP pages. You can add URLs to the Batch Wizard's target list and validate the document that comes back from the server after it has been processed. This method allows you to test the HTML output of your scripts and programs.

Drag and Drop Window Tips

NOTE: Because many users do not use the Drag and Drop Window feature, the Drag and Drop menu is hidden by default. To show it on the main menu, make sure that there is a check mark in front of the View->Menus->Drag and Drop menu option.

A way of processing multiple targets without the Batch Wizard is to use the Drag and Drop Window. If you want to validate all the HTML documents in a folder and its subfolders, then you can use Microsoft Windows' Find Files or Folders command to search for all the HTML documents in a folder and its subfolders. Remember that you can sort by file type (in details view) to consecutively list all your HTML documents. You can then select the entire list of found files and drop them onto the Drag and Drop Window to validate them, use a tool on them, or do both at the same time.

When validating many documents this way, you can leave *.val files only for the documents that contain errors or warnings. For example, if you have a document named "C:\html\page1.html" and this document contains errors or warnings, then HTML Validator will create a file called "C:\html\page1.html.val" that contains the actual error and/or warning messages. If "C:\html\page1.html" does not contain any errors or warnings, then "C:\html\page1.html.val" will not exist.

Doing the above is a good way to validate a site with many documents. You can drag and drop all the site's documents onto HTML Validator's Drag and Drop Window and then scan the folder for the val files. To do this, go to Options->Validator Engine Options and the Validator Engine->Classic page. Uncheck 'Always open viewer after check'. Check 'Don't use output file; use .val files', 'Never open viewer with .val files' (unless you want to), and 'If no errors/warnings, then don't view'. Press the OK button. Make sure that the Drag and Drop Window is visible by making sure that Drag and Drop->View Drag and Drop Window is checked. You can then drag and drop the files that you want to check onto the Drag and Drop Window and val files should be created for documents that you drag and drop and that contain any errors or warnings. You can use Windows Explorer or Find Files or Folders to drag the files from (or almost anything else that you can drag files from).

When using the Drag and Drop Window, you can double-click it to revalidate the last document validated.

Other Tips

USE AS SOURCE VIEWER - (tick_16Pro, tick_16Std, tick_16Lite) You may be able to configure your web browser to use HTML Validator as an HTML source viewer. You can then easily validate HTML from your web browser! Simply tell your browser to use cmdlineprocessor.exe as the source viewer. For Internet Explorer users, CSE HTML Validator has an Options->Internet Explorer Source Viewer->Make Source Viewer in Internet Explorer menu option to easily make the needed changes in the registry.

BOOKMARKS - When editing large documents, try using bookmarks. You'll quickly find them very convenient and useful. Simply press Shift+Ctrl+# to set a bookmark and Ctrl+# to go back to the bookmark. # is a number from 0 to 9. View the gutter to see where the bookmarks are set. This is a great time saver.

RELOADING - You can easily "reload" documents that are opened from the web by choosing Reload from the editor context menu, choosing File->Reload, or using the shortcut Shift+Ctrl+R.

INTEGRATED WEB BROWSER - (tick_16Pro, tick_16Std, cross_16Lite) Make use of the integrated web browser to browse the web while displaying the HTML source and validating it. This feature is great for checking the HTML output of dynamic web pages such as ASP and PHP pages.