CSE HTML Validator includes some "tools" (described in more detail below) that you may find useful. They include:

Convert Text File Format

Format & Fix HTML (HTML Tidy Tool)

Quick Lowercase Tags

Quick Quote Attribute Values

Quick Remove Tags

Quick Uppercase Tags

Template - See How to Use the Template Tool

To use one of the tools, select it from the Tools menu. For most tools, the currently selected document in the editor is used as the source document for the tool. For other tools, such as the Convert Text File Format Tool, you will be prompted for the document that you wish to process with the selected tool. Enter the filename of the document you want to process and press the Open button in the dialog box. CSE HTML Validator will then rename the selected file with a ".bak" extension and replace the original filename with the processed file. The ".bak" file will be automatically deleted if the Tools leave .bak files on disk option in the Validator Engine Options, Tools tab is unchecked.

Template Tool  (tick_16All Editions)

CSE HTML Validator also includes a simple but powerful tool called the Template Tool. The template tool is capable of saving a web developer from spending a tremendous amount of time making the same changes to many documents. For example, using the template tool, a header or footer can be changed on hundreds of documents in just minutes (or seconds) without the need for any scripting like ASP or PHP. This tool is even included in the lite edition.

Using the Drag and Drop Window  (tick_16All Editions)

Multiple files can be quickly processed with a tool using the Drag and Drop Window. To view this window, use the menu option Drag and Drop->View Drag and Drop Window. Use the Drag and Drop Default Tool Select dialog box to select what tool to use and then drag and drop the files that you want to process onto the Drag and Drop Window. For example, select the files (one or more) that you want to process in Windows Explorer and then drag and drop them onto the Drag and Drop Window. You can drop many files at once onto the Drag and Drop Window.

NOTE: Because many users do not use the Drag and Drop Window feature, the Drag and Drop menu is hidden by default. To show it on the main menu, make sure that there is a check mark in front of the View->Menus->Drag and Drop menu option.

If you are using the professional edition, then you can also use the Batch Wizard to easily process multiple files with a tool. CSE HTML Validator Pro also supports a Link Check tool that allows you to easily check the links of a website.

Tool Descriptions

All tools should work on Unix (LF) and Macintosh (CR) files as well as MS-DOS text files (CRLF), however, they will all produce an MS-DOS file that can then be changed to another type if necessary.

Convert Text File Format Tool - (tick_16All Editions) This tool replaces CR, LF, or CRLF characters with new end of line characters that depend on the text file format selected in the 'Tools' page of the Validator Engine Options. If you are working with Unix text files (such as HTML documents) for instance, then you can convert them to an MS-DOS text file format by specifying MS-DOS format in the program options and then using this tool to convert the file. You can then edit these files with Notepad or another text editor on your PC. One very useful feature of this tool is that you can convert entire folders of files by dragging and dropping all of the files in a folder onto HTML Validator's Drag and Drop Window and using this tool on the dragged and dropped files. Note that if you try to convert an MS-DOS file to MS-DOS, Unix to Unix, or Mac to Mac, this tool will do nothing to the file, so you don't have to worry about having already converted the documents.

HTML Tidy Tool - (tick_16Pro, tick_16Std, cross_16Lite) This is a powerful tool that uses HTML Tidy to automatically fix certain mistakes and problems, change documents to/from HTML and XHTML, and format ("pretty print") documents. There are two "versions", or methods of using this tool. One is with the HTML Tidy Tool dialog box and another without it. With the dialog box method, you can preview the results and change the options until you are satisfied or you choose to cancel. When the dialog box method is not used, HTML Tidy is run with the current options and the results are automatically accepted (no dialog box is displayed).

Quick Lowercase Tags Tool - (tick_16All Editions) Processing a file with this tool will change all alphabetic characters between the characters < and > to lowercase. Exceptions are characters in tags that are enclosed in double or single quotation marks, characters between <! and >, and characters between <!-- and --> (comments). This tool will also ignore characters in ASP and PHP blocks. Be careful! If you have certain improper syntax in the document (such as in scripts), it may not work properly. You should always keep backups of your previous work.

Quick Quote Attribute Values Tool - (tick_16All Editions) This tool attempts to enclose all attribute values in double quotes if the attribute value is not already in single or double quotation marks.

Quick Remove Tags Tool - (tick_16All Editions) This tool attempts to remove all HTML tags and their attributes from an HTML document and leave only the text with no HTML. This could also be considered an "extract text" tool. Character references are not removed.

Quick Uppercase Tags Tool - (tick_16All Editions) This performs the same operation as the lowercase tool except that lowercase alphabetic characters are changed to uppercase.

Template Tool - (tick_16All Editions) This tool allows you to create HTML documents based on a certain template. If you then need to later change the template it was based on, simply change the template file and then reprocess all of the HTML documents with this tool (you can drag and drop your HTML documents onto HTML Validator's Drag and Drop Window to quickly reprocess them with the template tool, or you can use the Batch Wizard). See also the How to Use the Template Tool topic.