Validate an Entire Website
(tick_24Pro, cross_24Std, cross_24Lite)

You can validate an entire website (or part of one) with a single URL or file using the Batch Wizard.

Validating an Entire Website With a Single URL or File

1.Open the Batch Wizard. Run CSE HTML Validator Pro or Enterprise and then choosing Tools->Batch Wizard or pressing F2.

2.Create a target list. Choose File->New List or press Ctrl+N to create a new target list, or you can load an previously saved target list with File->Open List.

3.Add the website's root URL or file. Add a target that specifies the root page of your website. This can be a URL or a local file. To add a local file target, press Ctrl+F. To add a URL, press Ctrl+U. For example, if your site is at "http://www.mydomain.com/mysite/" then press Ctrl+U to add the URL "http://www.mydomain.com/mysite/" to the target list. You can also specify a folder where your website files are located by adding a folder target (Ctrl+D).

4.View the target's properties. The Target Properties Dialog for the target you just added may appear automatically with the Follow Links Tab pre-selected. If not, then select the target that you just added and press F5 to view the target's properties.

5.Make sure links will be followed. Select the Follow Links Tab (if not already selected) and check the 'Follow and validate links' option. Click OK.

6.Setup the job options. Go to Options->Batch Wizard Options, press F4, or use the button on the toolbar. Choose the 'Tool to Use' page and select the 'Validator' tool as the tool to use. You can also optionally select a validation mode, like 'Full', 'Errors only' or 'Errors and warnings only'. Select OK when done

7.Setup the target list options. Select the Target List Options Tab and setup the options specific to the current target list. These options allow finer control over which targets to include and exclude, which links to check, and more.

8.Start the job. Choose File->Start Processing, press the Start button on the toolbar, or press F6 to start the validation and process the target list.

9.View the results. By default, an HTML report should automatically open when the validation is complete.

NOTE: The trial version may be limited to checking a small number of documents so that the limited number of trial validations are not quickly used up. To fully use the Batch Wizard, a licensed version is required.

NOTE: Large websites may require the enterprise edition's capability to handle larger jobs. The enterprise edition also includes additional Batch Wizard features.

More Information

Batch Wizard jobs can be run from the command line.

See the Batch Wizard topic for more information about the Batch Wizard.

See the Batch Wizard Troubleshooting topic if you encounter problems.