Using the Batch Wizard
(tick_24Pro, cross_24Std, cross_24Lite)

Using the Batch Wizard

1.Open the Batch Wizard. Run CSE HTML Validator Pro or Enterprise and then choosing Tools->Batch Wizard or pressing F2.

2.Create a target list. Create a list of targets that you want to process (i.e. validate). This is called a target list. Targets can be files, URLs, or folders. To add targets, use the Target menu, toolbar, or the context/pop-up menu for the Target List tab. You can also drag and drop files and folders onto the target list to add them. Duplicate targets that are already in the target list cannot and will not be added again.

3.Save the target list. When you've added all the targets to the target list, we recommend that you save the target list (though this is not required). You can do this by choosing File->Save List. You can save the target list in the folder where HTML Validator is installed or in any other folder.

4.Setup the job options. Go to Options->Batch Wizard Options, press F4, or use the button on the toolbar.

5.Setup the target list options. Select the Target List Options Tab and setup the options specific to the current target list. These options allow finer control over which targets to include and exclude, which links to check, and more.

6.Setup the target options for each target. You can view and/or change the options for the individual targets by viewing the target's properties. Do this if you are validating the targets and you want the Batch Wizard to follow the links in a target so that the links are validated too. Again, you may want to save any changes you make by saving the target list.

7.Start the job. Press the Start button on the toolbar (or press F6). The progress will be displayed in the Batch Progress tab. If you want to abort the processing, then you can press the Stop button on the toolbar (or press F7). Depending on where the Batch Wizard is in the processing cycle will determine how long it is until the processing is actually aborted so you may have to wait a few seconds for the processing to stop after you hit the Stop button.

8.View results. If you used the validator, spell check, or link check tool on the targets, then you can view the validation, spell check, or link check report when processing is completed. When completed, the report will open automatically unless you have changed the options to not automatically open the report. If you used another tool, such as the template tool, then reports are not generated.

9.Repeat when desired. To process the list again press the Start button (or press F6) again. To make sure that all targets are processed again, you may first want to choose Target->All Targets->Set Process to Yes.

See also the Validate an Entire Website and Batch Wizard Tips topics.

Using the Batch Wizard Directly from the Editor

You can use the Batch Wizard to quickly generate an HTML validation report for the web document that you are editing in HTML Validator's integrated editor by selecting Validate->Validate with Batch Wizard or by pressing Shift+F2 in the integrated editor. To validate all the non-empty documents that are open in the editor and that are recognized (by file extension) as checkable documents, select Validate->Validate All with Batch Wizard or press Alt+F2.